summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-07-10 15:16:46 -0400
committerMike Gilbert <floppym@gentoo.org>2019-07-10 15:18:21 -0400
commit00836d82034a9c252a90a0e31f48e930c04ae6f0 (patch)
tree97b89a681e44f6485f299e11c0cc2b20ec9079f4 /sys-apps/systemd/systemd-9999.ebuild
parentsys-apps/systemd: remove unused patch (diff)
downloadgentoo-00836d82034a9c252a90a0e31f48e930c04ae6f0.tar.gz
gentoo-00836d82034a9c252a90a0e31f48e930c04ae6f0.tar.bz2
gentoo-00836d82034a9c252a90a0e31f48e930c04ae6f0.zip
sys-apps/systemd: restore DEPEND="${COMMON_DEPEND}"
Closes: https://bugs.gentoo.org/686536 Package-Manager: Portage-2.3.68, Repoman-2.3.16_p2 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 7769725c2c29..27de1bc2e194 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -64,6 +64,12 @@ COMMON_DEPEND=">=sys-apps/util-linux-2.30:0=[${MULTILIB_USEDEP}]
selinux? ( sys-libs/libselinux:0= )
xkb? ( >=x11-libs/libxkbcommon-0.4.1:0= )"
+# Newer linux-headers needed by ia64, bug #480218
+DEPEND="${COMMON_DEPEND}
+ >=sys-kernel/linux-headers-${MINKV}
+ gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
+"
+
# baselayout-2.2 has /run
RDEPEND="${COMMON_DEPEND}
>=sys-apps/baselayout-2.2
@@ -88,12 +94,6 @@ PDEPEND=">=sys-apps/dbus-1.9.8[systemd]
policykit? ( sys-auth/polkit )
!vanilla? ( sys-apps/gentoo-systemd-integration )"
-# Newer linux-headers needed by ia64, bug #480218
-DEPEND="
- >=sys-kernel/linux-headers-${MINKV}
- gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
-"
-
BDEPEND="
app-arch/xz-utils:0
dev-util/gperf
@@ -237,7 +237,7 @@ multilib_src_configure() {
-Delfutils=$(meson_multilib_native_use elfutils)
-Dgcrypt=$(meson_use gcrypt)
-Dgnu-efi=$(meson_multilib_native_use gnuefi)
- -Defi-libdir="${EPREFIX}/usr/$(get_libdir)"
+ -Defi-libdir="${ESYSROOT}/usr/$(get_libdir)"
-Dmicrohttpd=$(meson_multilib_native_use http)
-Dimportd=$(meson_multilib_native_use importd)
-Dbzip2=$(meson_multilib_native_use importd)