summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-10-26 14:16:20 -0400
committerMike Gilbert <floppym@gentoo.org>2019-10-26 14:17:02 -0400
commit86e02411b44c6add8ed40c90994e6b72474dce06 (patch)
treec8da670d1b1be2271cd61675acb00f6e547c9ee6 /sys-apps/systemd/systemd-9999.ebuild
parentwww-client/httrack: Fix openssl dependency (diff)
downloadgentoo-86e02411b44c6add8ed40c90994e6b72474dce06.tar.gz
gentoo-86e02411b44c6add8ed40c90994e6b72474dce06.tar.bz2
gentoo-86e02411b44c6add8ed40c90994e6b72474dce06.zip
sys-apps/systemd: always pass -Drootlibdir=/usr/...
This ensures the pkgconfig file points to the correct directory for static linking. Package-Manager: Portage-2.3.78_p4, Repoman-2.3.17_p100 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 261851cf5bbc..0bb00e81ae53 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -237,6 +237,7 @@ multilib_src_configure() {
# make sure we get /bin:/sbin in PATH
-Dsplit-usr=$(usex split-usr true false)
-Drootprefix="$(usex split-usr "${EPREFIX:-/}" "${EPREFIX}/usr")"
+ -Drootlibdir="${EPREFIX}/usr/$(get_libdir)"
-Dsysvinit-path=
-Dsysvrcnd-path=
# Avoid infinite exec recursion, bug 642724
@@ -305,12 +306,6 @@ multilib_src_configure() {
-Dstatic-libudev=$(usex static-libs true false)
)
- if multilib_is_native_abi; then
- myconf+=( -Drootlibdir="${EPREFIX}$(usex split-usr '' /usr)/$(get_libdir)" )
- else
- myconf+=( -Drootlibdir="${EPREFIX}/usr/$(get_libdir)" )
- fi
-
meson_src_configure "${myconf[@]}"
}
@@ -370,12 +365,9 @@ multilib_src_install_all() {
# Avoid breaking boot/reboot
dosym ../../../lib/systemd/systemd /usr/lib/systemd/systemd
dosym ../../../lib/systemd/systemd-shutdown /usr/lib/systemd/systemd-shutdown
-
- if use static-libs; then
- mv "${ED}/$(get_libdir)"/lib{systemd,udev}.a "${ED}/usr/$(get_libdir)/" || die
- gen_usr_ldscript lib{systemd,udev}.so
- fi
fi
+
+ gen_usr_ldscript -a systemd udev
}
migrate_locale() {