summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-05-24 00:37:10 -0400
committerMike Gilbert <floppym@gentoo.org>2018-05-24 00:37:10 -0400
commitf602af077d978ba8982ced38021ab97e90b7fcca (patch)
tree8204e0a6d5d5b426a5b91321048630cf493d411c /sys-apps/systemd/systemd-9999.ebuild
parentsys-apps/systemd: remove old (diff)
downloadgentoo-f602af077d978ba8982ced38021ab97e90b7fcca.tar.gz
gentoo-f602af077d978ba8982ced38021ab97e90b7fcca.tar.bz2
gentoo-f602af077d978ba8982ced38021ab97e90b7fcca.zip
sys-apps/systemd: rename usrmerge to split-usr and invert the meaning
Package-Manager: Portage-2.3.37, Repoman-2.3.9_p219
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 999d766f966c..4d9bb8b9004b 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd"
LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0/2"
-IUSE="acl apparmor audit build cryptsetup curl elfutils +gcrypt gnuefi http idn importd +kmod libidn2 +lz4 lzma nat pam pcre policykit qrcode +resolvconf +seccomp selinux ssl +sysv-utils test usrmerge vanilla xkb"
+IUSE="acl apparmor audit build cryptsetup curl elfutils +gcrypt gnuefi http idn importd +kmod libidn2 +lz4 lzma nat pam pcre policykit qrcode +resolvconf +seccomp selinux +split-usr ssl +sysv-utils test vanilla xkb"
REQUIRED_USE="importd? ( curl gcrypt lzma )"
RESTRICT="!test? ( test )"
@@ -203,8 +203,8 @@ multilib_src_configure() {
# avoid bash-completion dep
-Dbashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in PATH
- -Dsplit-usr=$(usex usrmerge false true)
- -Drootprefix="$(usex usrmerge "${EPREFIX}/usr" "${EPREFIX:-/}")"
+ -Dsplit-usr=$(usex split-usr true false)
+ -Drootprefix="$(usex split-usr "${EPREFIX:-/}" "${EPREFIX}/usr")"
-Dsysvinit-path=
-Dsysvrcnd-path=
# Avoid infinite exec recursion, bug 642724
@@ -297,7 +297,7 @@ multilib_src_install() {
}
multilib_src_install_all() {
- local rootprefix=$(usex usrmerge /usr '')
+ local rootprefix=$(usex split-usr '' /usr)
# meson doesn't know about docdir
mv "${ED%/}"/usr/share/doc/{systemd,${PF}} || die
@@ -336,11 +336,11 @@ multilib_src_install_all() {
rm -fr "${ED%/}"/etc/systemd/system/sysinit.target.wants || die
local udevdir=/lib/udev
- use usrmerge && udevdir=/usr/lib/udev
+ use split-usr || udevdir=/usr/lib/udev
rm -r "${ED%/}${udevdir}/hwdb.d" || die
- if ! use usrmerge; then
+ if use split-usr; then
# Avoid breaking boot/reboot
dosym ../../../lib/systemd/systemd /usr/lib/systemd/systemd
dosym ../../../lib/systemd/systemd-shutdown /usr/lib/systemd/systemd-shutdown