summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-26 21:05:37 +0000
committerSam James <sam@gentoo.org>2020-12-26 21:05:37 +0000
commitd49fb7d7cba3535c064677d1b12fe9e9a37391e9 (patch)
tree307c7ef6c20f867c054d38374163ee92736e043c /sys-apps/texinfo
parentsys-libs/ncurses: drop ~m68k-mint (diff)
downloadgentoo-d49fb7d7cba3535c064677d1b12fe9e9a37391e9.tar.gz
gentoo-d49fb7d7cba3535c064677d1b12fe9e9a37391e9.tar.bz2
gentoo-d49fb7d7cba3535c064677d1b12fe9e9a37391e9.zip
sys-apps/texinfo: sync with ::prefix
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/files/texinfo-4.13-mint.patch63
-rw-r--r--sys-apps/texinfo/texinfo-6.7.ebuild13
2 files changed, 75 insertions, 1 deletions
diff --git a/sys-apps/texinfo/files/texinfo-4.13-mint.patch b/sys-apps/texinfo/files/texinfo-4.13-mint.patch
new file mode 100644
index 000000000000..b4533939c478
--- /dev/null
+++ b/sys-apps/texinfo/files/texinfo-4.13-mint.patch
@@ -0,0 +1,63 @@
+patch by Alan Hourihane for FreeMiNT
+http://archives.gentoo.org/gentoo-alt/msg_d2ac4e586d9c51b1d4e46f555e899cc9.xml
+
+diff -u gnulib/lib/mbiter.h gnulib/lib/mbiter.h
+--- gnulib/lib/mbiter.h 2008-05-12 12:38:21.000000000 +0000
++++ gnulib/lib/mbiter.h 2008-11-19 21:13:17.000000000 +0000
+@@ -117,8 +117,10 @@
+ {
+ if (iter->next_done)
+ return;
++#if (HAVE_MBSINIT && HAVE_MBRTOWC)
+ if (iter->in_shift)
+ goto with_shift;
++#endif
+ /* Handle most ASCII characters quickly, without calling mbrtowc(). */
+ if (is_basic (*iter->cur.ptr))
+ {
+@@ -129,6 +131,7 @@
+ iter->cur.wc = *iter->cur.ptr;
+ iter->cur.wc_valid = true;
+ }
++#if (HAVE_MBSINIT && HAVE_MBRTOWC)
+ else
+ {
+ assert (mbsinit (&iter->state));
+@@ -169,6 +172,7 @@
+ iter->in_shift = false;
+ }
+ }
++#endif
+ iter->next_done = true;
+ }
+
+diff -u gnulib/lib/mbuiter.h gnulib/lib/mbuiter.h
+--- gnulib/lib/mbuiter.h 2007-12-25 23:57:18.000000000 +0000
++++ gnulib/lib/mbuiter.h 2008-11-19 21:15:12.000000000 +0000
+@@ -125,8 +125,10 @@
+ {
+ if (iter->next_done)
+ return;
++#if (HAVE_MBSINIT && HAVE_MBRTOWC)
+ if (iter->in_shift)
+ goto with_shift;
++#endif
+ /* Handle most ASCII characters quickly, without calling mbrtowc(). */
+ if (is_basic (*iter->cur.ptr))
+ {
+@@ -137,6 +139,7 @@
+ iter->cur.wc = *iter->cur.ptr;
+ iter->cur.wc_valid = true;
+ }
++#if (HAVE_MBSINIT && HAVE_MBRTOWC)
+ else
+ {
+ assert (mbsinit (&iter->state));
+@@ -178,6 +181,7 @@
+ iter->in_shift = false;
+ }
+ }
++#endif
+ iter->next_done = true;
+ }
+
diff --git a/sys-apps/texinfo/texinfo-6.7.ebuild b/sys-apps/texinfo/texinfo-6.7.ebuild
index cee372613a77..01d16d60a612 100644
--- a/sys-apps/texinfo/texinfo-6.7.ebuild
+++ b/sys-apps/texinfo/texinfo-6.7.ebuild
@@ -15,10 +15,11 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls +standalone static"
RDEPEND="
+ !=app-text/tetex-2*
>=sys-libs/ncurses-5.2-r2:0=
standalone? ( dev-lang/perl )
!standalone? (
@@ -31,6 +32,16 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="nls? ( >=sys-devel/gettext-0.19.6 )"
+src_prepare() {
+ default
+
+ if use prefix ; then
+ eapply -p0 "${FILESDIR}"/${PN}-4.13-mint.patch
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1
+ fi
+}
+
src_configure() {
# Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"