summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2018-02-20 18:29:41 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-20 22:38:49 +0100
commit68d4b4f7e4b523d3a27474f594edac1498f2bf5e (patch)
tree715d25412110c99e194cf11dd26b22cc8f1662b3 /sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild
parentnet-libs/zmqpp: version bump to 4.2.0. (diff)
downloadgentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.tar.gz
gentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.tar.bz2
gentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.zip
sys-apps/thunderbolt-software-user-space: new package.
thunderbolt-software-user-space is a tool to talk to the tunderbolt kernel driver and approve thunderbolt devices. Closes: https://bugs.gentoo.org/648312 Closes: https://github.com/gentoo/gentoo/pull/7239 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild')
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild
new file mode 100644
index 000000000000..98f4f364ebe1
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils linux-info
+DESCRIPTION="Thunderbolt(TM) user-space components"
+HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+app-text/txt2tags
+dev-libs/boost
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ CONFIG_CHECK="THUNDERBOLT"
+ ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
+ CONFIG_CHECK="HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderpolt needs pci hotplug support, so please enable it."
+ check_extra_config
+}