summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-03-10 16:40:18 +0100
committerPatrick Lauer <patrick@gentoo.org>2017-03-10 16:40:37 +0100
commitee89c242b98ca6da797b83f9939995c10f6a6f4c (patch)
tree6fb5a87a67f3cc16eab886a1721e108409c889e2 /sys-apps/toybox/toybox-0.7.3.ebuild
parentnet-libs/nodejs: Bump, remove old (diff)
downloadgentoo-ee89c242b98ca6da797b83f9939995c10f6a6f4c.tar.gz
gentoo-ee89c242b98ca6da797b83f9939995c10f6a6f4c.tar.bz2
gentoo-ee89c242b98ca6da797b83f9939995c10f6a6f4c.zip
sys-apps/toybox: Bump
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'sys-apps/toybox/toybox-0.7.3.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.7.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/toybox/toybox-0.7.3.ebuild b/sys-apps/toybox/toybox-0.7.3.ebuild
new file mode 100644
index 000000000000..855407636080
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.7.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gfto/toybox.git"
+else
+ SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+ restore_config .config
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ tc-export CC STRIP
+ export HOSTCC=$(tc-getBUILD_CC)
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin generated/unstripped/toybox toybox
+}