summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-06-27 17:47:54 -0400
committerMike Gilbert <floppym@gentoo.org>2021-06-27 17:50:22 -0400
commit50d96c6315095f31ea0893153a0641e7cbd36d64 (patch)
tree23a99440be1f050ec34607e807d52f7c0e5e1cb3 /sys-apps/toybox/toybox-0.8.5.ebuild
parentnet-vpn/ocserv: depend on virtual/libcrypt (diff)
downloadgentoo-50d96c6315095f31ea0893153a0641e7cbd36d64.tar.gz
gentoo-50d96c6315095f31ea0893153a0641e7cbd36d64.tar.bz2
gentoo-50d96c6315095f31ea0893153a0641e7cbd36d64.zip
sys-apps/toybox: depend on virtual/libcrypt
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/toybox/toybox-0.8.5.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.8.5.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/toybox/toybox-0.8.5.ebuild b/sys-apps/toybox/toybox-0.8.5.ebuild
deleted file mode 100644
index ca78edf8b366..000000000000
--- a/sys-apps/toybox/toybox-0.8.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multiprocessing savedconfig toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/landley/toybox.git"
-else
- SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Common linux commands in a multicall binary"
-HOMEPAGE="https://landley.net/code/toybox/"
-
-LICENSE="0BSD"
-SLOT="0"
-
-src_prepare() {
- default
- restore_config .config
-}
-
-src_configure() {
- tc-export CC STRIP
- export HOSTCC="$(tc-getBUILD_CC)"
- # Respect CFLAGS
- export OPTIMIZE="${CFLAGS}"
-
- if [[ -f .config ]]; then
- yes "" | emake -j1 oldconfig > /dev/null
- return 0
- else
- einfo "Could not locate user configfile, so we will save a default one"
- emake -j1 defconfig > /dev/null
- fi
-}
-
-src_compile() {
- unset CROSS_COMPILE
- export CPUS=$(makeopts_jobs)
- emake V=1
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- save_config .config
- newbin generated/unstripped/toybox toybox
-}