summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild')
-rw-r--r--sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild b/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild
new file mode 100644
index 000000000000..ed0a880e02cc
--- /dev/null
+++ b/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="User Interface for TuxOnIce"
+HOMEPAGE="http://www.tuxonice.net"
+SRC_URI="http://tuxonice.net/files/${P}.tar.gz -> ${P}.tar
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV}-2~exp1.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="fbsplash"
+
+DEPEND="fbsplash? (
+ >=app-arch/bzip2-1.0.6-r3[static-libs]
+ >=media-gfx/splashutils-1.5.2.1
+ media-libs/freetype[static-libs]
+ media-libs/libmng
+ >=media-libs/libpng-1.4.8[static-libs]
+ virtual/jpeg
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+ epatch "${FILESDIR}"/${P}-freetype-2.5.patch
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+ sed -i -e 's/ -O3//' Makefile fbsplash/Makefile usplash/Makefile || die
+}
+
+src_compile() {
+ # Package contain binaries
+ emake clean
+
+ use fbsplash && export USE_FBSPLASH=1
+ emake CC="$(tc-getCC)" tuxoniceui
+}
+
+src_install() {
+ into /
+ dosbin tuxoniceui
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ elog "You must create a symlink from /etc/splash/tuxonice"
+ elog "to the theme you want tuxonice to use, e.g.:"
+ elog
+ elog " # ln -sfn /etc/splash/emergence /etc/splash/tuxonice"
+ if [[ ${REPLACING_VERSIONS} < 1.1 ]]; then
+ einfo
+ elog "You must refer to '/sbin/tuxoniceui -f' instead of /sbin/tuxoniceui_fbsplash'"
+ elog "in all places you set it."
+ fi
+ fi
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.* for further"
+ einfo "instructions."
+ einfo
+}