summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-22 13:10:13 +0300
committerLars Wendler <polynomial-c@gentoo.org>2019-05-23 07:31:29 +0200
commit9da8cfa6b2bfad2636acbb51cedaf5ce2eef89d3 (patch)
treebbd36d0d8447199f080f4bf634bf3529ed53029c /sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild
parentsys-apps/ucspi-proxy: bump version to 1.1 (diff)
downloadgentoo-9da8cfa6b2bfad2636acbb51cedaf5ce2eef89d3.tar.gz
gentoo-9da8cfa6b2bfad2636acbb51cedaf5ce2eef89d3.tar.bz2
gentoo-9da8cfa6b2bfad2636acbb51cedaf5ce2eef89d3.zip
sys-apps/ucspi-unix: bump version to 1.0
Temporarily mask it since it depends on masked >=dev-libs/bglibs-2.04. Closes: https://bugs.gentoo.org/678926 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12080 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild')
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild b/sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild
new file mode 100644
index 000000000000..dd48c88398ce
--- /dev/null
+++ b/sys-apps/ucspi-unix/ucspi-unix-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A UCSPI implementation for Unix domain sockets"
+HOMEPAGE="https://untroubled.org/ucspi-unix/"
+SRC_URI="https://untroubled.org/ucspi-unix/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# We statically link bglibs.
+DEPEND=">=dev-libs/bglibs-2.04"
+# Block other unixcat installers. #480546
+RDEPEND="!net-analyzer/mk-livestatus"
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} -D_GNU_SOURCE" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dobin unixserver unixclient unixcat
+ doman unixserver.1 unixclient.1
+ dodoc ANNOUNCEMENT ChangeLog NEWS PROTOCOL README TODO
+}