summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-25 05:14:30 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-25 05:22:00 -0500
commitf3272c36fcc0c21df2e5afa928d4bbf9607728aa (patch)
tree7c6cd35db6d5b1c33d7b1b92692afe31f5150978 /sys-apps/usbutils
parentmedia-gfx/jhead: Tested on ~x86, requested by Amynka (diff)
downloadgentoo-f3272c36fcc0c21df2e5afa928d4bbf9607728aa.tar.gz
gentoo-f3272c36fcc0c21df2e5afa928d4bbf9607728aa.tar.bz2
gentoo-f3272c36fcc0c21df2e5afa928d4bbf9607728aa.zip
sys-apps/usbutils: version bump to 009
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/Manifest1
-rw-r--r--sys-apps/usbutils/usbutils-009.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/usbutils/Manifest b/sys-apps/usbutils/Manifest
index ae1b4b72f8eb..5aff102e3b25 100644
--- a/sys-apps/usbutils/Manifest
+++ b/sys-apps/usbutils/Manifest
@@ -1 +1,2 @@
DIST usbutils-008.tar.xz 287052 SHA256 44741af0bae9d402a0ef160a29b2fa700bb656ab5e0a4b3343d51249c2a44c8c SHA512 ab1ad36467ff79ff5ab0b924620001612cae44def58c05ade01a4e58d8a4d48df61c09faba49a20497b7d6314045bbaf137b51a9f4e6b65ed0ea3bb339bf1c45 WHIRLPOOL 47898f8f0c8a93a200777e5006ec36c2bc805e126974ba415edc21983db9d35d3b8ec4a6be28359a36e5adda95cc4c8bc37ba4b651a9065e249b8ffe4c6b70aa
+DIST usbutils-009.tar.xz 309608 BLAKE2B bb5d7f756241377e81aa8f5b074bb0ba36bc778698afaebf7054cdb153149e4f3808a7b172019434756cae8b33410643cd6a03a36277f80ead9b0f4446385fd9 SHA512 e5936a42615690c13e618655fc5eb4f414d9a84f85b860eaeb3bcf737258e05d299b09d1c5388d50c718626036ec8cac5d670ad567ceadfaab85f401f0744a8a
diff --git a/sys-apps/usbutils/usbutils-009.ebuild b/sys-apps/usbutils/usbutils-009.ebuild
new file mode 100644
index 000000000000..ee9aba52d6dc
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-009.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="virtual/libusb:1=
+ virtual/libudev:="
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hwids
+ python? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use python && python_fix_shebang lsusb.py.in
+}
+
+src_configure() {
+ econf \
+ --datarootdir="${EPREFIX}/usr/share" \
+ --datadir="${EPREFIX}/usr/share/misc"
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+
+ use python || rm -f "${ED}"/usr/bin/lsusb.py
+}