summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-06 10:07:12 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-06 10:07:12 +0100
commitfa0d9458e284f8b403aa746d288a49052833fb68 (patch)
tree2c3c83eedacb9df75350a5a8d0c03697aefbf9d4 /sys-apps/util-linux
parentsys-apps/sed: remove userland_GNU (diff)
downloadgentoo-fa0d9458e284f8b403aa746d288a49052833fb68.tar.gz
gentoo-fa0d9458e284f8b403aa746d288a49052833fb68.tar.bz2
gentoo-fa0d9458e284f8b403aa746d288a49052833fb68.zip
sys-apps/util-linux: remove userland_GNU
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.37.2-r1.ebuild39
-rw-r--r--sys-apps/util-linux/util-linux-2.37.2-r3.ebuild39
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild39
3 files changed, 24 insertions, 93 deletions
diff --git a/sys-apps/util-linux/util-linux-2.37.2-r1.ebuild b/sys-apps/util-linux/util-linux-2.37.2-r1.ebuild
index 46c6b0ce7ed2..619414e131e1 100644
--- a/sys-apps/util-linux/util-linux-2.37.2-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.37.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs su +suid systemd test tty-helpers udev unicode"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -97,13 +97,6 @@ src_prepare() {
-e "s|UUIDD_SOCKET=\"\$(mktemp -u \"\${TS_OUTDIR}/uuiddXXXXXXXXXXXXX\")\"|UUIDD_SOCKET=\"\$(mktemp -u \"${T}/uuiddXXXXXXXXXXXXX.sock\")\"|g" \
tests/ts/uuid/uuidd || die "Failed to fix uuidd test"
- if ! use userland_GNU ; then
- # test runner is using GNU-specific xargs call
- sed -i -e 's:xargs:gxargs:' tests/run.sh || die
- # test requires util-linux uuidgen (which we don't build)
- rm tests/ts/uuid/oids || die
- fi
-
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
@@ -132,14 +125,10 @@ python_configure() {
--disable-bash-completion
--without-systemdsystemunitdir
--with-python
+ --enable-libblkid
+ --enable-libmount
+ --enable-pylibmount
)
- if use userland_GNU ; then
- myeconfargs+=(
- --enable-libblkid
- --enable-libmount
- --enable-pylibmount
- )
- fi
mkdir "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" >/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -188,8 +177,7 @@ multilib_src_configure() {
$(use_with ncurses tinfo)
$(use_with selinux)
)
- # build programs only on GNU, on *BSD we want libraries only
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
myeconfargs+=(
--disable-chfn-chsh
--disable-login
@@ -236,13 +224,8 @@ multilib_src_configure() {
--enable-libblkid
--enable-libsmartcols
--enable-libfdisk
+ --enable-libmount
)
- if use userland_GNU ; then
- # those libraries don't work on *BSD
- myeconfargs+=(
- --enable-libmount
- )
- fi
fi
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -293,7 +276,7 @@ multilib_src_install() {
# This needs to be called AFTER python_install call (#689190)
emake DESTDIR="${D}" install
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
# need the libs in /
gen_usr_ldscript -a blkid fdisk mount smartcols uuid
fi
@@ -305,12 +288,6 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
find "${ED}" -name "*.la" -delete || die
- if ! use userland_GNU ; then
- # manpage collisions
- # TODO: figure out a good way to keep them
- rm "${ED}"/usr/share/man/man3/uuid* || die
- fi
-
if use pam ; then
newpamd "${FILESDIR}/runuser.pamd" runuser
newpamd "${FILESDIR}/runuser-l.pamd" runuser-l
diff --git a/sys-apps/util-linux/util-linux-2.37.2-r3.ebuild b/sys-apps/util-linux/util-linux-2.37.2-r3.ebuild
index 9532360938eb..29ca2387ed7a 100644
--- a/sys-apps/util-linux/util-linux-2.37.2-r3.ebuild
+++ b/sys-apps/util-linux/util-linux-2.37.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs +su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs +su +suid systemd test tty-helpers udev unicode"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -97,13 +97,6 @@ src_prepare() {
-e "s|UUIDD_SOCKET=\"\$(mktemp -u \"\${TS_OUTDIR}/uuiddXXXXXXXXXXXXX\")\"|UUIDD_SOCKET=\"\$(mktemp -u \"${T}/uuiddXXXXXXXXXXXXX.sock\")\"|g" \
tests/ts/uuid/uuidd || die "Failed to fix uuidd test"
- if ! use userland_GNU ; then
- # test runner is using GNU-specific xargs call
- sed -i -e 's:xargs:gxargs:' tests/run.sh || die
- # test requires util-linux uuidgen (which we don't build)
- rm tests/ts/uuid/oids || die
- fi
-
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
@@ -132,14 +125,10 @@ python_configure() {
--disable-bash-completion
--without-systemdsystemunitdir
--with-python
+ --enable-libblkid
+ --enable-libmount
+ --enable-pylibmount
)
- if use userland_GNU ; then
- myeconfargs+=(
- --enable-libblkid
- --enable-libmount
- --enable-pylibmount
- )
- fi
mkdir "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" >/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -188,8 +177,7 @@ multilib_src_configure() {
$(use_with ncurses tinfo)
$(use_with selinux)
)
- # build programs only on GNU, on *BSD we want libraries only
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
myeconfargs+=(
--disable-chfn-chsh
--disable-login
@@ -236,13 +224,8 @@ multilib_src_configure() {
--enable-libblkid
--enable-libsmartcols
--enable-libfdisk
+ --enable-libmount
)
- if use userland_GNU ; then
- # those libraries don't work on *BSD
- myeconfargs+=(
- --enable-libmount
- )
- fi
fi
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -293,7 +276,7 @@ multilib_src_install() {
# This needs to be called AFTER python_install call (#689190)
emake DESTDIR="${D}" install
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
# need the libs in /
gen_usr_ldscript -a blkid fdisk mount smartcols uuid
fi
@@ -305,12 +288,6 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
find "${ED}" -name "*.la" -delete || die
- if ! use userland_GNU ; then
- # manpage collisions
- # TODO: figure out a good way to keep them
- rm "${ED}"/usr/share/man/man3/uuid* || die
- fi
-
if use pam ; then
# See https://github.com/util-linux/util-linux/blob/master/Documentation/PAM-configuration.txt
newpamd "${FILESDIR}/runuser.pamd" runuser
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 8ba7230d848f..3fdf6c85b949 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs +su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat +hardlink kill +logger magic ncurses nls pam python +readline rtas selinux slang static-libs +su +suid systemd test tty-helpers udev unicode"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -92,13 +92,6 @@ src_prepare() {
-e "s|UUIDD_SOCKET=\"\$(mktemp -u \"\${TS_OUTDIR}/uuiddXXXXXXXXXXXXX\")\"|UUIDD_SOCKET=\"\$(mktemp -u \"${T}/uuiddXXXXXXXXXXXXX.sock\")\"|g" \
tests/ts/uuid/uuidd || die "Failed to fix uuidd test"
- if ! use userland_GNU ; then
- # test runner is using GNU-specific xargs call
- sed -i -e 's:xargs:gxargs:' tests/run.sh || die
- # test requires util-linux uuidgen (which we don't build)
- rm tests/ts/uuid/oids || die
- fi
-
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
@@ -127,14 +120,10 @@ python_configure() {
--disable-bash-completion
--without-systemdsystemunitdir
--with-python
+ --enable-libblkid
+ --enable-libmount
+ --enable-pylibmount
)
- if use userland_GNU ; then
- myeconfargs+=(
- --enable-libblkid
- --enable-libmount
- --enable-pylibmount
- )
- fi
mkdir "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" >/dev/null || die
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -183,8 +172,7 @@ multilib_src_configure() {
$(use_with ncurses tinfo)
$(use_with selinux)
)
- # build programs only on GNU, on *BSD we want libraries only
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
myeconfargs+=(
--disable-chfn-chsh
--disable-login
@@ -231,13 +219,8 @@ multilib_src_configure() {
--enable-libblkid
--enable-libsmartcols
--enable-libfdisk
+ --enable-libmount
)
- if use userland_GNU ; then
- # those libraries don't work on *BSD
- myeconfargs+=(
- --enable-libmount
- )
- fi
fi
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -288,7 +271,7 @@ multilib_src_install() {
# This needs to be called AFTER python_install call (#689190)
emake DESTDIR="${D}" install
- if multilib_is_native_abi && use userland_GNU ; then
+ if multilib_is_native_abi ; then
# need the libs in /
gen_usr_ldscript -a blkid fdisk mount smartcols uuid
fi
@@ -300,12 +283,6 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
find "${ED}" -name "*.la" -delete || die
- if ! use userland_GNU ; then
- # manpage collisions
- # TODO: figure out a good way to keep them
- rm "${ED}"/usr/share/man/man3/uuid* || die
- fi
-
if use pam ; then
# See https://github.com/util-linux/util-linux/blob/master/Documentation/PAM-configuration.txt
newpamd "${FILESDIR}/runuser.pamd" runuser