summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-13 22:24:09 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 22:24:09 +0200
commit9b79f1b4b7cc46dc8e2cab90bd087f42b3dbf8ae (patch)
tree1f1f87cbdf61e19a7bde240faa1aa0ec2cc1b05b /sys-apps/watchdog
parentsys-block/aoetools: Remove old 36 (diff)
downloadgentoo-9b79f1b4b7cc46dc8e2cab90bd087f42b3dbf8ae.tar.gz
gentoo-9b79f1b4b7cc46dc8e2cab90bd087f42b3dbf8ae.tar.bz2
gentoo-9b79f1b4b7cc46dc8e2cab90bd087f42b3dbf8ae.zip
sys-apps/watchdog: Remove old 5.15
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/watchdog')
-rw-r--r--sys-apps/watchdog/Manifest1
-rw-r--r--sys-apps/watchdog/files/watchdog-5.15-musl-nfs.patch27
-rw-r--r--sys-apps/watchdog/files/watchdog-5.15-musl.patch23
-rw-r--r--sys-apps/watchdog/files/watchdog-init.d47
-rw-r--r--sys-apps/watchdog/watchdog-5.15.ebuild41
5 files changed, 0 insertions, 139 deletions
diff --git a/sys-apps/watchdog/Manifest b/sys-apps/watchdog/Manifest
index 644169d7c3a1..9da68e1e0985 100644
--- a/sys-apps/watchdog/Manifest
+++ b/sys-apps/watchdog/Manifest
@@ -1,2 +1 @@
-DIST watchdog-5.15.tar.gz 228132 BLAKE2B 040badcf66f048e2873c335a4dd1b5dad6716c61534322c0c92dad2238049555af40e92612a260507fddd4c284d7ccb5d362dc1660084fd0a7db2c522b1ea323 SHA512 a675cfadf3296d583b9163193297038fb19459daf7c6681289392d613e775e75b7afd42a3e01b136a955f25b2f45818033b56e10de9050075d7dc015535a6e75
DIST watchdog-5.16.tar.gz 203910 BLAKE2B 517f2f8085829e5c5ff576f1dff920a2667d0e96a71dcbcebf381ccf349e95dfb0b7b598b565eda4cc8ec31f5f34e367dd719eeaf522cdee074c3bc23589dfb2 SHA512 1c9c921570ec7ddc3e4ff88b2029f1c3865277e547fb8970575df4b61fdf1f06f443f49ad09f11c29d913ca7d6ab05c5b19ec049ac218a8bcebd20b1bf5f0bbd
diff --git a/sys-apps/watchdog/files/watchdog-5.15-musl-nfs.patch b/sys-apps/watchdog/files/watchdog-5.15-musl-nfs.patch
deleted file mode 100644
index bee4ddc8d7bc..000000000000
--- a/sys-apps/watchdog/files/watchdog-5.15-musl-nfs.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-commit f52c40680f0aad44b9ae16648803453ec00cbb2c
-Author: Paul Crawford <psc@sat.dundee.ac.uk>
-Date: Fri Dec 30 15:55:45 2016 +0000
-
- Compile with musl when nfs is disabled
-
- musl does by default not ship with rpc headers. The watchdog should
- not require rpc headers when nfs support is disabled.
-
- Patch by Felix Janda <fjanda@users.sf.net>
-
-diff --git a/include/sundries.h b/include/sundries.h
-index 4379982..98c489a 100644
---- a/include/sundries.h
-+++ b/include/sundries.h
-@@ -9,9 +9,11 @@
- #include <signal.h>
- #include <stdarg.h>
- #include <stdlib.h>
-+#if HAVE_NFS
- #if !defined(bool_t) && !defined(__GLIBC__)
- #include <rpc/types.h>
- #endif
-+#endif
-
- extern int mount_mount_quiet;
- extern int mount_verbose;
diff --git a/sys-apps/watchdog/files/watchdog-5.15-musl.patch b/sys-apps/watchdog/files/watchdog-5.15-musl.patch
deleted file mode 100644
index ae62c8014e5b..000000000000
--- a/sys-apps/watchdog/files/watchdog-5.15-musl.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit c5cb4e1a0339844ae3f55ff1dc4a716c28012f05
-Author: Paul Crawford <psc@sat.dundee.ac.uk>
-Date: Tue Jun 28 18:08:48 2016 +0100
-
- Include linux/param.h for EXEC_PAGESIZE definition
-
- Musl does not include linux/param.h whereas glibc does, so it fails
- to build on musl. Patch supplied by Khem Raj <raj.khem@gmail.com>
-
-diff --git a/src/watchdog.c b/src/watchdog.c
-index acf6450..486384a 100644
---- a/src/watchdog.c
-+++ b/src/watchdog.c
-@@ -26,6 +26,9 @@
- #include <sys/param.h> /* For EXEC_PAGESIZE */
- #include <linux/oom.h>
- #include <linux/watchdog.h>
-+#ifdef __linux__
-+#include <linux/param.h>
-+#endif
- #include <string.h>
-
- #include <libgen.h>
diff --git a/sys-apps/watchdog/files/watchdog-init.d b/sys-apps/watchdog/files/watchdog-init.d
deleted file mode 100644
index 734a02cdbcbe..000000000000
--- a/sys-apps/watchdog/files/watchdog-init.d
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount
- use logger
-}
-
-get_config() {
- set -- ${WATCHDOG_OPTS}
- while [ -n "$1" ] ; do
- if [ "$1" = "-c" -o "$1" = "--config-file" ] ; then
- echo $2
- return
- fi
- shift
- done
- echo /etc/watchdog.conf
-}
-
-get_delay() {
- # man this is fugly
- sed -n \
- -e '1{x;s:.*:10:;x}' \
- -e 's:#.*::' \
- -e 's:^[[:space:]]*::' \
- -e '/^interval/{s:.*=::;h}' \
- -e '${g;p}' \
- $(get_config)
-}
-
-start() {
- ebegin "Starting watchdog"
- start-stop-daemon --start \
- --exec /usr/sbin/watchdog --pidfile /var/run/watchdog.pid \
- -- ${WATCHDOG_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping watchdog"
- start-stop-daemon --stop \
- --exec /usr/sbin/watchdog --pidfile /var/run/watchdog.pid \
- --retry $(get_delay)
- eend $?
-}
diff --git a/sys-apps/watchdog/watchdog-5.15.ebuild b/sys-apps/watchdog/watchdog-5.15.ebuild
deleted file mode 100644
index 889279958581..000000000000
--- a/sys-apps/watchdog/watchdog-5.15.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic systemd toolchain-funcs
-
-DESCRIPTION="A software watchdog and /dev/watchdog daemon"
-HOMEPAGE="https://sourceforge.net/projects/watchdog/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sparc x86"
-IUSE="nfs"
-
-RDEPEND="nfs? ( net-libs/libtirpc )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-musl.patch
- "${FILESDIR}"/${P}-musl-nfs.patch
-)
-
-src_configure() {
- if use nfs; then
- append-cppflags "$($(tc-getPKG_CONFIG) libtirpc --cflags)"
- append-libs "$($(tc-getPKG_CONFIG) libtirpc --libs)"
- fi
- econf $(use_enable nfs)
-}
-
-src_install() {
- default
- dodoc -r examples
-
- newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
- newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
- systemd_dounit "${FILESDIR}"/watchdog.service
-}