summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 13:45:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 13:50:23 +0100
commit1e737b86e3744b30afea6088b845722932426f7a (patch)
tree0e31ecfb110768c7b4fc17562738f2cf4773e8bb /sys-apps/xdg-desktop-portal
parentkde-misc/tellico: 3.3.5 version bump (diff)
downloadgentoo-1e737b86e3744b30afea6088b845722932426f7a.tar.gz
gentoo-1e737b86e3744b30afea6088b845722932426f7a.tar.bz2
gentoo-1e737b86e3744b30afea6088b845722932426f7a.zip
sys-apps/xdg-desktop-portal: 1.8.1 version bump
Reported-by: Gabriel <gabriel@gagv.org.uk> Closes: https://bugs.gentoo.org/771180 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 71f4da8f86b1..1cd6d721c764 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.8.0.tar.xz 470692 BLAKE2B f21da5ad11dc2b1611983fdac87335b3c7e9c13222bbe3b90b276d75726a6f16d950a9ba62606aa31d52f57b8d076393ec0d48014b1623ab03dee23c524ed0ef SHA512 6d9760b41447af711d5937279b0031bcc88947e11204351accfcd9e6e19e498e9021675753185f92f7bd40336decc1895968796b1b71508c7caf5f6fc32a51a4
+DIST xdg-desktop-portal-1.8.1.tar.xz 473052 BLAKE2B a7d0aa2aa1e8220ced3e4abff8a8284c521b983ce807cd3e0d7b5d22f98f6428b6de9a193ae3aced9c13473617f453d13d0af83c677e3d077906b6cf8a138d45 SHA512 447d287d6627a1086d97dc5ebda20dfb1d0ca8643cbe54a7af5f6205a122a7be9d1643fded592f922c015561b7e2f4c6b6df555db3e0d3c02aad5bbe944077b6
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.1.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.1.ebuild
new file mode 100644
index 000000000000..a976a7e8f8db
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ )
+ econf "${myeconfargs[@]}"
+}