summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-23 11:47:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-23 12:37:41 +0100
commitbdc5b9088edbd12075e484af9c89185d45d3ea61 (patch)
tree355590243e86f2d78ffd7d2edb0d4916355adf0d /sys-apps/xdg-desktop-portal
parentdev-python/QtPy: add version 2.0.0 (diff)
downloadgentoo-bdc5b9088edbd12075e484af9c89185d45d3ea61.tar.gz
gentoo-bdc5b9088edbd12075e484af9c89185d45d3ea61.tar.bz2
gentoo-bdc5b9088edbd12075e484af9c89185d45d3ea61.zip
sys-apps/xdg-desktop-portal: 1.12.1 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index cd2c3da3e135..3ff5801a04f5 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.10.1.tar.xz 479660 BLAKE2B 88a2b8ea890036bf0d4192fae4ae143e350d903a528e09a0bd7ffc7bda2a58b5c04ae80f1cec4357bb05cba8db417b6193fc6ef7f7dd65bf414f80a8ac2800c5 SHA512 5db0bd866674ff016d864646ea7f91f09a1b8fbc5ec735e4c97165af71770d2c7d3333e771062644dd522b32f67ead72bc7ef99186e3b069671c174d4d601fdc
+DIST xdg-desktop-portal-1.12.1.tar.xz 484352 BLAKE2B afa14ab78f35cb1c0e66514f313f5dc297ceef88af1ca7b3028305faa8398bdae1b9e897289b18a93b1cda1a8290c0e51bf73e66c9dce231f57a58652fb9e120 SHA512 62df427e2d8d54acd9a34a02a77c26ae3911fbb4c5844eff4a253dc839775c929c6945401b93549ba200ba637d315146767e41f18a831d7627b35de880de0da1
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild
new file mode 100644
index 000000000000..1b6590b6ba9b
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ )
+ econf "${myeconfargs[@]}"
+}