summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-08-14 15:26:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-08-14 15:26:54 -0500
commited5f6696bafe792cb780a6702aed09ed684c3e57 (patch)
tree0d56374601af730f86154ab80a2a6a48d0ce1c47 /sys-apps/yarn/yarn-1.9.4.ebuild
parentprofiles/updates/4Q-2014: pgasync removed (diff)
downloadgentoo-ed5f6696bafe792cb780a6702aed09ed684c3e57.tar.gz
gentoo-ed5f6696bafe792cb780a6702aed09ed684c3e57.tar.bz2
gentoo-ed5f6696bafe792cb780a6702aed09ed684c3e57.zip
sys-apps/yarn: 1.9.4 bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps/yarn/yarn-1.9.4.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.9.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/yarn/yarn-1.9.4.ebuild b/sys-apps/yarn/yarn-1.9.4.ebuild
new file mode 100644
index 000000000000..b4b5ee7ead80
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+
+ while read -r -d '' path; do
+ read -r shebang < ${path} || die
+ [[ "${shebang}" == \#\!* ]] || continue
+ chmod +x "${path}" || die #614094
+ done < <(find "${ED}" -type f -print0 || die)
+}