summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/yum
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/yum')
-rw-r--r--sys-apps/yum/Manifest1
-rw-r--r--sys-apps/yum/metadata.xml11
-rw-r--r--sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild44
-rw-r--r--sys-apps/yum/yum-3.4.3_p20130218.ebuild43
4 files changed, 99 insertions, 0 deletions
diff --git a/sys-apps/yum/Manifest b/sys-apps/yum/Manifest
new file mode 100644
index 000000000000..b70b9c24bc89
--- /dev/null
+++ b/sys-apps/yum/Manifest
@@ -0,0 +1 @@
+DIST yum-3.4.3_p20130218.tar.gz 1389537 SHA256 efc2daeca86ddc893eb0489342686eb4a2b2cbbd1a75fd42fd27624225494ce7 SHA512 b450c6133443f674bd60f59633d5669d9f88e60930657891f428ce8f1bdcf7124a86ed756a6a5912b9237788854331022119a6bfb1d5cac8d8fdc3de11b1020e WHIRLPOOL 18bcff3b9f2e991f255ac5bc07937e67c20df46ec88fff1481e5f64fc36f97e5d741cfb378c4731a1721f1d0a9beb6f9d37a5f91b59055cfcb21ac06fce819b6
diff --git a/sys-apps/yum/metadata.xml b/sys-apps/yum/metadata.xml
new file mode 100644
index 000000000000..6b829015b14f
--- /dev/null
+++ b/sys-apps/yum/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Automatic updater and package installer/remover for rpm
+ systems
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild b/sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild
new file mode 100644
index 000000000000..727290ba75cd
--- /dev/null
+++ b/sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+MY_PV="a119004"
+MY_P="${PN}-${MY_PV}"
+
+inherit eutils multilib python-single-r1
+
+DESCRIPTION="automatic updater and package installer/remover for rpm systems"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/rpm[${PYTHON_USEDEP}]
+ dev-python/sqlitecachec[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/pyliblzma[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+ sed -i -e "s:lib:$(get_libdir):g" rpmUtils/Makefile yum/Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ python_optimize "${D%/}$(python_get_sitedir)" "${ED%/}/usr/share/yum-cli"
+ rm -r "${ED%/}/etc/rc.d" || die
+}
diff --git a/sys-apps/yum/yum-3.4.3_p20130218.ebuild b/sys-apps/yum/yum-3.4.3_p20130218.ebuild
new file mode 100644
index 000000000000..7ba98ba2e925
--- /dev/null
+++ b/sys-apps/yum/yum-3.4.3_p20130218.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+MY_PV="a119004"
+MY_P="${PN}-${MY_PV}"
+
+inherit eutils multilib python-single-r1
+
+DESCRIPTION="automatic updater and package installer/remover for rpm systems"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/rpm[${PYTHON_USEDEP}]
+ dev-python/sqlitecachec[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+ sed -i -e "s:lib:$(get_libdir):g" rpmUtils/Makefile yum/Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ python_optimize "${D%/}$(python_get_sitedir)" "${ED%/}/usr/share/yum-cli"
+ rm -r "${ED%/}/etc/rc.d" || die
+}