summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-12-04 16:22:27 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-12-04 16:23:49 -0600
commit01a8fe0d681e5fa84435c5a9052227424adc29a6 (patch)
tree04e65978e598966e8e139b25eae8d93267790837 /sys-apps
parentsys-apps/openrc: version bump (diff)
downloadgentoo-01a8fe0d681e5fa84435c5a9052227424adc29a6.tar.gz
gentoo-01a8fe0d681e5fa84435c5a9052227424adc29a6.tar.bz2
gentoo-01a8fe0d681e5fa84435c5a9052227424adc29a6.zip
sys-apps/kmod: version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/Manifest1
-rw-r--r--sys-apps/kmod/kmod-22.ebuild190
2 files changed, 191 insertions, 0 deletions
diff --git a/sys-apps/kmod/Manifest b/sys-apps/kmod/Manifest
index 7421ceb3810c..f452a5e5f838 100644
--- a/sys-apps/kmod/Manifest
+++ b/sys-apps/kmod/Manifest
@@ -1,2 +1,3 @@
DIST kmod-20.tar.xz 437880 SHA256 89c1a1a2193c31f9ebe582640bfa2bd401341dc24119f5a7f702588116fadaa0 SHA512 1026d80486e6c823fc74a439d15a8b1e4a501140f67568165904b43a73130133d6c84075ec8a7981a5d4a187d5fbd21afd197de4e81cc05a66506711865edf96 WHIRLPOOL 938d1ea4d153c04231b89701c7a7f602d31166e5c85bb6f2798ba0a7c22a4961f05bdd8631d985785212e5bf359d1cd12c4088fd9c2a07d8b6b9a77599e84a39
DIST kmod-21.tar.xz 446460 SHA256 160a9448af74cf75b08d089f37a3e8d1fafa75cce92d1cbe869a753b670d95c0 SHA512 93d9c7eda3a04ed94c6531087614d92b5a65a2e642bd3af017a3a8a458a78a5a57acb1707e35bf3a0aa8f22ab0fa99d34cf4e7dd568f202a18eb49fb52bf78c1 WHIRLPOOL 78aa8c086ed8129b3a686f3b7d46e224c09f018fc85cda041bfac253afa8056e3e403eedbedb81be4c2354075040dcb6a526c2295cc3b393a76cb3896491cea3
+DIST kmod-22.tar.xz 449724 SHA256 ba3b1ddea33228b473189fcb05b809024a3b86e9a7cf37d420cae06beb749f82 SHA512 e021bacebb07ba4a178215ca1d1e091195fed1d289a76ec3ddb309182a90b6eab19d98eb1331772bc739f73ed6f540d92213b8088a573df13cd28ebd333a8876 WHIRLPOOL ed5b338698f250a0cb344da0789099a4fcdd098a1d64ed0f912fbb361ee91eaf13ceffec28e95757778a687ed8ed8acce16c0717000c598237e01abda256ca1c
diff --git a/sys-apps/kmod/kmod-22.ebuild b/sys-apps/kmod/kmod-22.ebuild
new file mode 100644
index 000000000000..ee2b045a4bfd
--- /dev/null
+++ b/sys-apps/kmod/kmod-22.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 eutils multilib python-r1
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+ inherit autotools git-2
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ inherit libtool
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc lzma python static-libs +tools zlib"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+# Block systemd below 217 for -static-nodes-indicate-that-creation-of-static-nodes-.patch
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/modutils
+ !<sys-apps/openrc-0.13.8
+ !<sys-apps/systemd-216-r3
+ lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
+ python? ( ${PYTHON_DEPS} )
+ zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ lzma? ( virtual/pkgconfig )
+ python? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ )
+ zlib? ( virtual/pkgconfig )"
+if [[ ${PV} == 9999* ]]; then
+ DEPEND="${DEPEND}
+ dev-libs/libxslt"
+fi
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS="NEWS README TODO"
+
+src_prepare() {
+ if [ ! -e configure ]; then
+ if use doc; then
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ elibtoolize
+ fi
+
+ # Restore possibility of running --enable-static wrt #472608
+ sed -i \
+ -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
+ configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --with-rootlibdir="${EPREFIX}/$(get_libdir)"
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable tools)
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ $(use_with lzma xz)
+ $(use_with zlib)
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ )
+
+ local ECONF_SOURCE="${S}"
+
+ kmod_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ run_in_build_dir econf "${myeconfargs[@]}" "$@"
+ }
+
+ BUILD_DIR="${WORKDIR}/build"
+ kmod_configure --disable-python
+
+ if use python; then
+ python_foreach_impl kmod_configure --enable-python
+ fi
+}
+
+src_compile() {
+ emake -C "${BUILD_DIR}"
+
+ if use python; then
+ local native_builddir=${BUILD_DIR}
+
+ python_compile() {
+ emake -C "${BUILD_DIR}" -f Makefile -f - python \
+ VPATH="${native_builddir}:${S}" \
+ native_builddir="${native_builddir}" \
+ libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) $(native_builddir)/libkmod/libkmod.la' \
+ <<< 'python: $(pkgpyexec_LTLIBRARIES)'
+ }
+
+ python_foreach_impl python_compile
+ fi
+}
+
+src_install() {
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+ einstalldocs
+
+ if use python; then
+ local native_builddir=${BUILD_DIR}
+
+ python_install() {
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" \
+ VPATH="${native_builddir}:${S}" \
+ install-pkgpyexecLTLIBRARIES \
+ install-dist_pkgpyexecPYTHON
+ }
+
+ python_foreach_impl python_install
+ fi
+
+ prune_libtool_files --modules
+
+ if use tools; then
+ local bincmd sbincmd
+ for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
+ dosym /bin/kmod /sbin/${sbincmd}
+ done
+
+ # These are also usable as normal user
+ for bincmd in lsmod modinfo; do
+ dosym kmod /bin/${bincmd}
+ done
+ fi
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ softdep uhci_hcd pre: ehci_hcd
+ softdep ohci_hcd pre: ehci_hcd
+ EOF
+
+ insinto /lib/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf #260139
+
+ newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
+}
+
+pkg_postinst() {
+ if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
+ ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
+ rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
+ fi
+
+ # Add kmod to the runlevel automatically if this is the first install of this package.
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
+ mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
+ fi
+ if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
+ ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
+ fi
+ fi
+
+ if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
+ if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
+ ewarn
+ ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
+ ewarn "kernel modules to have required static nodes!"
+ ewarn "Run this command:"
+ ewarn "\trc-update add kmod-static-nodes sysinit"
+ fi
+ fi
+}