summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-28 02:34:17 +0100
committerSam James <sam@gentoo.org>2023-07-28 02:35:15 +0100
commit1851a3dad29e89bf8bbfd8fbdae261aeb43259fd (patch)
tree3e1097356005f2b469663ab7bd4cd8cc33ed4bd5 /sys-apps
parentsys-fs/zfs: drop 2.2.0_rc1, 2.2.0_rc2 (diff)
downloadgentoo-1851a3dad29e89bf8bbfd8fbdae261aeb43259fd.tar.gz
gentoo-1851a3dad29e89bf8bbfd8fbdae261aeb43259fd.tar.bz2
gentoo-1851a3dad29e89bf8bbfd8fbdae261aeb43259fd.zip
sys-apps/pv: add 1.7.17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/pv-1.7.17.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 1e63935c250e..5479ab411eeb 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1,2 +1,3 @@
DIST pv-1.6.20.tar.bz2 115310 BLAKE2B b50623f623231e8e8615f960bad83d10e12d5274c57d23ea843d16fce30b3e690284b2d9b01f82a16b9790e2bf26f80f560e226589a62ca677a2cf90ea007691 SHA512 e445f91b298ed285ddab54a3f8a6b5d5297e2e2eb8ad7b2ee2cbacca4adda9c6ca2bf3c77bf2a93373d3875c5b3b0b345d3945cbd91fc2647c6c25f1661a6752
DIST pv-1.7.0.tar.bz2 115665 BLAKE2B efdd0434d23fe1ed008224fe0fe5182684010a78650284e920b2cd93134f08e63172df0279b8a4b2c2c4dceb9dbdaa209e402394fb1c4c431d991225f579f718 SHA512 b90ddaa1f950b1b300f1721e5ab8bc2c7a0c46491e439ce33c7b74fd4525e730a99c218a874b3dae2dc3a8a5e0eb5c5add51f7c8be48d0c3d8f135df44779af8
+DIST pv-1.7.17.tar.bz2 133398 BLAKE2B e0167af81988225418c2647c7051910fd41ef1e631eb26ab56fa44449064f99f5cc90bf08143a9e1158d656d9cee234a9ca4924ff5d95fd1f4814d340499af47 SHA512 b6c347681d937492d575007df35a7b90cb9283537df2e2258742787626c7041f942322a3140c8976793b6ddcd9cb2ecdaa7bf6e02914f394ebf748e3f97b2f64
diff --git a/sys-apps/pv/pv-1.7.17.ebuild b/sys-apps/pv/pv-1.7.17.ebuild
new file mode 100644
index 000000000000..e42a3b03fad0
--- /dev/null
+++ b/sys-apps/pv/pv-1.7.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de fr pl pt"
+PLOCALE_BACKUP="en"
+inherit linux-info toolchain-funcs plocale
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml"
+SRC_URI="https://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls"
+
+DOCS=( README.md doc/NEWS.md doc/TODO.md )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+
+ disable_locale() {
+ local locale=${1}
+ sed -i configure -e "/ALL_LINGUAS=/s:${locale}::g" || die
+ }
+
+ plocale_find_changes src/nls '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+}
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}
+
+src_test() {
+ emake -Onone check
+}