summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-16 16:59:03 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-16 17:04:17 +0200
commit19ee2121603ebe06cffd5f0e0c6253528465e697 (patch)
tree3168c41e760dc67b2c40071505c3a71e8656cd58 /sys-apps
parentsys-kernel/gentoo-sources: Linux patch 4.14.144 (diff)
downloadgentoo-19ee2121603ebe06cffd5f0e0c6253528465e697.tar.gz
gentoo-19ee2121603ebe06cffd5f0e0c6253528465e697.tar.bz2
gentoo-19ee2121603ebe06cffd5f0e0c6253528465e697.zip
sys-apps/fakeroot: bump to v1.24
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.24.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index 32410d87432a..9367a0ac8521 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1,2 +1,3 @@
DIST fakeroot_1.22.orig.tar.bz2 338238 BLAKE2B b6cee7483ea7ec17747e638cbfefa565f26b3b00517f3ec90280f8ce556ce8efa3833accc07885365e20f80967a67291fadc27cd80766548cc86e2aa70c74c33 SHA512 193478d9ff88ca2ae69fe47b73b6c61aeb2ba3f2a9e7ed5d455022705857c6f34cdcbe2d3f614c4c4c9509368dc78b9a7b7aa56fb3b50bb3309448140abd796a
DIST fakeroot_1.23.orig.tar.xz 298080 BLAKE2B eac3da8486d57266f0f6af0479f0fcec5aaf82f4707ad8f810f954373a31cf5f390ef57dcc71ba630a1d4a578df95ac9beda9c93b3c75adffcbc89860f442b69 SHA512 0984679207e6e340abf715d4b26a213f85420cd8c58f21e65eb069337a3bd67436c6f80168412c10b28701689ec63290f122a5ff5d44a57b2b166aa72799d036
+DIST fakeroot_1.24.orig.tar.gz 522497 BLAKE2B fb08ed6512a3e26538662ceb28a197b85fd4a05c37b543529df6880e01c64bd774037bed1230bf7d7fe0bde798364c2fd0fcfab257fff4d3e6ae9800c076a5b0 SHA512 b15db7bbfb03264f294fb3b42813e17758b43ef7f121e55a24af9ec30ff3f4ec8eb0392db88133e56f9728b3828f6c1432d1e5d2e881a69d083ad444b9177487
diff --git a/sys-apps/fakeroot/fakeroot-1.24.ebuild b/sys-apps/fakeroot/fakeroot-1.24.ebuild
new file mode 100644
index 000000000000..336e7ca459d8
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug static-libs test"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
+ "${FILESDIR}"/${PN}-1.20.2-glibc-2.24.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+}