summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-20 01:45:43 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-20 01:45:43 +0200
commit1c4a51032de933388a99d7500c667a9bc83dba17 (patch)
treef1045a3ab5e84b1ab75195c735d5ec1815a70d68 /sys-apps
parentnet-analyzer/net-snmp: arm stable (bug #743538) (diff)
downloadgentoo-1c4a51032de933388a99d7500c667a9bc83dba17.tar.gz
gentoo-1c4a51032de933388a99d7500c667a9bc83dba17.tar.bz2
gentoo-1c4a51032de933388a99d7500c667a9bc83dba17.zip
sys-apps/syslog-notify: Port to EAPI 7
Closes: https://bugs.gentoo.org/670528 Closes: https://bugs.gentoo.org/742092 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.2.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/sys-apps/syslog-notify/syslog-notify-0.2.ebuild b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
index 35fc40806b20..c77dd707397c 100644
--- a/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
+++ b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit readme.gentoo
+EAPI=7
+
+inherit readme.gentoo-r1
DESCRIPTION="Notifications for syslog entries via libnotify"
HOMEPAGE="https://jtniehof.github.com/syslog-notify/"
@@ -11,26 +12,29 @@ SRC_URI="https://github.com/downloads/jtniehof/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
DEPEND=">=x11-libs/libnotify-0.7"
-RDEPEND="${DEPEND}
- || ( app-admin/syslog-ng app-admin/rsyslog )"
+RDEPEND="
+ ${DEPEND}
+ || (
+ app-admin/syslog-ng
+ app-admin/rsyslog
+ )"
+
+src_install() {
+ default
+ dodoc HACKING
+
+ dodir /var/spool
+ keepdir /var/spool
-pkg_setup() {
- DOCS="AUTHORS CHANGELOG HACKING README"
- DISABLE_AUTOFORMATTING="yes"
- DOC_CONTENTS="Add the following options on your /etc/syslog-ng/syslog-ng.conf
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="Add the following options on your /etc/syslog-ng/syslog-ng.conf
file:
# destination notify { pipe("/var/spool/syslog-notify"); };
# log { source(src); destination(notify);};
Remember to restart syslog-ng before starting syslog-notify."
-}
-
-src_install() {
- default
- dodir /var/spool
readme.gentoo_create_doc
}