summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-28 17:17:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-28 17:34:51 +0200
commit215a088fdcd48340fecfd0462d4c76aa671c8e86 (patch)
tree4414815f962c85c5eee062850a23dbe9411baf0b /sys-apps
parentprofiles: Mask ~sys-apps/xdg-desktop-portal-1.7.2 (diff)
downloadgentoo-215a088fdcd48340fecfd0462d4c76aa671c8e86.tar.gz
gentoo-215a088fdcd48340fecfd0462d4c76aa671c8e86.tar.bz2
gentoo-215a088fdcd48340fecfd0462d4c76aa671c8e86.zip
sys-apps/xdg-desktop-portal: 1.7.2 version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index cc68c2db6f09..7e453754e2f4 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.6.0.tar.xz 453516 BLAKE2B 13ffcb21de6b61ddeb0782dcfc7b684287e54f94b9494b19589178594d1383a15048b8f9aeed7fb1260c3a2c967b267061d1db401085a686938c8629de8824c3 SHA512 7a0c702851762a55326142cb6b470205775284e0f749620ae6b648f216afcd684f8b20500339680b42812f628634344c9e826ab7cf13dd918fdbf733381d44ce
+DIST xdg-desktop-portal-1.7.2.tar.xz 468140 BLAKE2B 6f2e92f79424f79e778db9c1bf94555332f1f88ef42f84e477c8784be74ce8e2cf924f34da5e17d78359bd493370dcee62aec77f60c9df5cf3475d745f3e4d8e SHA512 fac64281e89d8bf17c6f1b3751c159d9ca6c2896b71bb83622411bf2dc9b7813974d19902c81c3576b325c98edf4dae22ccc3fe290e32f717730b6aa3afbdc12
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.7.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.7.2.ebuild
new file mode 100644
index 000000000000..5037ce682d40
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ )
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ media-libs/fontconfig
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-libportal # not packaged
+ )
+ econf "${myeconfargs[@]}"
+}