summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-12 03:01:56 +0100
committerSam James <sam@gentoo.org>2021-09-12 03:02:16 +0100
commit21f28ec0d7360893d1a552693b503799a7ddba5a (patch)
tree1a338ddbb731eb54ed9bfed6a6afc45c8e7b5de4 /sys-apps
parentprofiles/arch/sparc: mask dev-util/ccache[doc] (diff)
downloadgentoo-21f28ec0d7360893d1a552693b503799a7ddba5a.tar.gz
gentoo-21f28ec0d7360893d1a552693b503799a7ddba5a.tar.bz2
gentoo-21f28ec0d7360893d1a552693b503799a7ddba5a.zip
sys-apps/fakeroot: add 1.26
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.26.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index 4a4f18037937..60c5be44cb64 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1 +1,2 @@
DIST fakeroot_1.25.3.orig.tar.gz 126884 BLAKE2B a6a860a8714bb2a43f2820bc586cac38d25df8b8cb32b219064618c845d0308b57929108bd582b46c15b2fe4b2fc00d662ba72458a9e9ffcf7d035dce515eb55 SHA512 b54366ef82b49af414d7214d069a4bc7dd188dfa4f8e3121f6bd65fd67268b02346ff72e857087243ab0efe9fa82faaa9f9c3309cac4b5af0ea00908c2e5eb6e
+DIST fakeroot_1.26.orig.tar.gz 549685 BLAKE2B d9177403d9c2be88c0949c891cde5742a405027714b07ca2c7e72813dba049157c3d994f30b9c634016a74c74745f8391ee51035cbf385ef63364d0a31291d43 SHA512 dad193b283b48a25806c5bcd06d1f5bbd183ccd40a3fc25f3e7bb88fd6579024f958321f8336654348a1d0a547d4ad19ed11aab5ec9441d6ef493ee6e4c78081
diff --git a/sys-apps/fakeroot/fakeroot-1.26.ebuild b/sys-apps/fakeroot/fakeroot-1.26.ebuild
new file mode 100644
index 000000000000..823e5a4ddf26
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.26.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+BDEPEND="app-text/po4a"
+
+DOCS=( AUTHORS BUGS DEBUG README doc/README.saving )
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+ use acl || export ac_cv_search_acl_get_fd=no # bug 759568
+ use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+
+ econf --disable-static
+}
+
+src_compile() {
+ # Create translated man pages
+ pushd doc >/dev/null || die
+ po4a -v -k 0 --variable "srcdir=${S}/doc/" po4a/po4a.cfg || die
+ popd >/dev/null || die
+
+ default
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}