summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 13:25:03 +0100
committerSam James <sam@gentoo.org>2022-10-30 15:50:17 +0000
commit2f8c0176b502f6150bec2e9d3523dd59b6223bf8 (patch)
treec01ca12ab615f043701cb3ba43c8eceea1fbf985 /sys-apps
parentgnome-base/gconf: Set remote-id (diff)
downloadgentoo-2f8c0176b502f6150bec2e9d3523dd59b6223bf8.tar.gz
gentoo-2f8c0176b502f6150bec2e9d3523dd59b6223bf8.tar.bz2
gentoo-2f8c0176b502f6150bec2e9d3523dd59b6223bf8.zip
sys-apps/sed: Install as gsed for better BSD compat.
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/sed-4.8-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/sed/sed-4.8-r1.ebuild b/sys-apps/sed/sed-4.8-r1.ebuild
new file mode 100644
index 000000000000..6cea28c227be
--- /dev/null
+++ b/sys-apps/sed/sed-4.8-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/sed.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.xz"
+SRC_URI+=" verify-sig? ( mirror://gnu/sed/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="acl nls selinux static"
+
+RDEPEND="
+ !static? (
+ acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )
+ )
+"
+DEPEND="${RDEPEND}
+ static? (
+ acl? ( virtual/acl[static-libs(+)] )
+ nls? ( virtual/libintl[static-libs(+)] )
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+ )
+"
+BDEPEND="nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-sed )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-avoid-noreturn-diagnostic.patch"
+)
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myconf=(
+ --exec-prefix="${EPREFIX}"
+ $(use_enable acl)
+ $(use_enable nls)
+ $(use_with selinux)
+ # rename to gsed for better BSD compatibility
+ --program-prefix=g
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ # symlink to the standard name
+ dosym gsed /bin/sed
+ dosym gsed.1 /usr/share/man/man1/sed.1
+}