summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 01:00:23 +0000
committerSam James <sam@gentoo.org>2022-01-13 01:00:23 +0000
commit3120e503cd505039303220cdb2fdad2ebb8d125b (patch)
treeb6b1f14ac71aeba6c815b1cc8a368031b82970d7 /sys-apps
parentmedia-libs/sdl2-ttf: fix harfbuzz dependency (diff)
downloadgentoo-3120e503cd505039303220cdb2fdad2ebb8d125b.tar.gz
gentoo-3120e503cd505039303220cdb2fdad2ebb8d125b.tar.bz2
gentoo-3120e503cd505039303220cdb2fdad2ebb8d125b.zip
sys-apps/iproute2: tidy up a bit
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/iproute2-5.16.0.ebuild24
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild26
2 files changed, 25 insertions, 25 deletions
diff --git a/sys-apps/iproute2/iproute2-5.16.0.ebuild b/sys-apps/iproute2/iproute2-5.16.0.ebuild
index c8e64f6852ee..c26a054ac839 100644
--- a/sys-apps/iproute2/iproute2-5.16.0.ebuild
+++ b/sys-apps/iproute2/iproute2-5.16.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs flag-o-matic multilib
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
@@ -46,8 +46,8 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug 643722
+ "${FILESDIR}"/${PN}-3.1.0-mtu.patch # bug #291907
+ "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
#"${FILESDIR}"/${PN}-5.1.0-portability.patch
"${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
)
@@ -60,7 +60,7 @@ doecho() {
src_prepare() {
if ! use ipv6 ; then
PATCHES+=(
- "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch #326849
+ "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch # bug #326849
)
fi
@@ -85,7 +85,7 @@ src_prepare() {
-e "/^DBM_INCLUDE/s:=.*:=${T}:" \
Makefile || die
- # build against system headers
+ # Build against system headers
rm -r include/netinet || die #include/linux include/ip{,6}tables{,_common}.h include/libiptc
sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
@@ -99,12 +99,12 @@ src_configure() {
# This sure is ugly. Should probably move into toolchain-funcs at some point.
local setns
- pushd "${T}" >/dev/null
+ pushd "${T}" >/dev/null || die
printf '#include <sched.h>\nint main(){return setns(0, 0);}\n' > test.c
${CC} ${CFLAGS} ${CPPFLAGS} -D_GNU_SOURCE ${LDFLAGS} test.c >&/dev/null && setns=y || setns=n
echo 'int main(){return 0;}' > test.c
${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} test.c -lresolv >&/dev/null || sed -i '/^LDLIBS/s:-lresolv::' "${S}"/Makefile
- popd >/dev/null
+ popd >/dev/null || die
# run "configure" script first which will create "config.mk"...
# Using econf breaks since 5.14.0 (a9c3d70d902a0473ee5c13336317006a52ce8242)
@@ -116,7 +116,7 @@ src_configure() {
TC_CONFIG_ATM := $(usex atm y n)
TC_CONFIG_XT := $(usex iptables y n)
TC_CONFIG_NO_XT := $(usex iptables n y)
- # We've locked in recent enough kernel headers #549948
+ # We've locked in recent enough kernel headers, bug #549948
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_CAP := $(usex caps y n)
@@ -124,7 +124,7 @@ src_configure() {
HAVE_ELF := $(usex elf y n)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
- # Use correct iptables dir, #144265 #293709
+ # Use correct iptables dir, bug #144265, bug #293709
IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
HAVE_LIBBSD := $(usex libbsd y n)
EOF
@@ -154,19 +154,19 @@ src_install() {
install
dodir /bin
- mv "${ED}"/{s,}bin/ip || die #330115
+ mv "${ED}"/{s,}bin/ip || die # bug #330115
dolib.a lib/libnetlink.a
insinto /usr/include
doins include/libnetlink.h
# This local header pulls in a lot of linux headers it
# doesn't directly need. Delete this header that requires
- # linux-headers-3.8 until that goes stable. #467716
+ # linux-headers-3.8 until that goes stable. # bug #467716
sed -i '/linux\/netconf.h/d' "${ED}"/usr/include/libnetlink.h || die
if use berkdb ; then
keepdir /var/lib/arpd
- # bug 47482, arpd doesn't need to be in /sbin
+ # bug #47482, arpd doesn't need to be in /sbin
dodir /usr/bin
mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
elif [[ -d "${ED}"/var/lib/arpd ]]; then
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index 367b3541cbfe..c26a054ac839 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs flag-o-matic multilib
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
@@ -46,8 +46,8 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug 643722
+ "${FILESDIR}"/${PN}-3.1.0-mtu.patch # bug #291907
+ "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
#"${FILESDIR}"/${PN}-5.1.0-portability.patch
"${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
)
@@ -60,7 +60,7 @@ doecho() {
src_prepare() {
if ! use ipv6 ; then
PATCHES+=(
- "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch #326849
+ "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch # bug #326849
)
fi
@@ -85,7 +85,7 @@ src_prepare() {
-e "/^DBM_INCLUDE/s:=.*:=${T}:" \
Makefile || die
- # build against system headers
+ # Build against system headers
rm -r include/netinet || die #include/linux include/ip{,6}tables{,_common}.h include/libiptc
sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
@@ -99,12 +99,12 @@ src_configure() {
# This sure is ugly. Should probably move into toolchain-funcs at some point.
local setns
- pushd "${T}" >/dev/null
+ pushd "${T}" >/dev/null || die
printf '#include <sched.h>\nint main(){return setns(0, 0);}\n' > test.c
${CC} ${CFLAGS} ${CPPFLAGS} -D_GNU_SOURCE ${LDFLAGS} test.c >&/dev/null && setns=y || setns=n
echo 'int main(){return 0;}' > test.c
${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} test.c -lresolv >&/dev/null || sed -i '/^LDLIBS/s:-lresolv::' "${S}"/Makefile
- popd >/dev/null
+ popd >/dev/null || die
# run "configure" script first which will create "config.mk"...
# Using econf breaks since 5.14.0 (a9c3d70d902a0473ee5c13336317006a52ce8242)
@@ -116,7 +116,7 @@ src_configure() {
TC_CONFIG_ATM := $(usex atm y n)
TC_CONFIG_XT := $(usex iptables y n)
TC_CONFIG_NO_XT := $(usex iptables n y)
- # We've locked in recent enough kernel headers #549948
+ # We've locked in recent enough kernel headers, bug #549948
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_CAP := $(usex caps y n)
@@ -124,7 +124,7 @@ src_configure() {
HAVE_ELF := $(usex elf y n)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
- # Use correct iptables dir, #144265 #293709
+ # Use correct iptables dir, bug #144265, bug #293709
IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
HAVE_LIBBSD := $(usex libbsd y n)
EOF
@@ -154,19 +154,19 @@ src_install() {
install
dodir /bin
- mv "${ED}"/{s,}bin/ip || die #330115
+ mv "${ED}"/{s,}bin/ip || die # bug #330115
dolib.a lib/libnetlink.a
insinto /usr/include
doins include/libnetlink.h
# This local header pulls in a lot of linux headers it
# doesn't directly need. Delete this header that requires
- # linux-headers-3.8 until that goes stable. #467716
+ # linux-headers-3.8 until that goes stable. # bug #467716
sed -i '/linux\/netconf.h/d' "${ED}"/usr/include/libnetlink.h || die
if use berkdb ; then
keepdir /var/lib/arpd
- # bug 47482, arpd doesn't need to be in /sbin
+ # bug #47482, arpd doesn't need to be in /sbin
dodir /usr/bin
mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
elif [[ -d "${ED}"/var/lib/arpd ]]; then