summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-27 12:38:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-27 12:40:32 +0200
commit367c7a144dafe9ce5e81eccc6bb4ee60af5b842b (patch)
tree5d7218bea6b7023de8439ef078054d4f3ded0022 /sys-apps
parentnet-misc/networkmanager: relax nss vs gnutls requirement (diff)
downloadgentoo-367c7a144dafe9ce5e81eccc6bb4ee60af5b842b.tar.gz
gentoo-367c7a144dafe9ce5e81eccc6bb4ee60af5b842b.tar.bz2
gentoo-367c7a144dafe9ce5e81eccc6bb4ee60af5b842b.zip
sys-apps/kbd: Backported vlock build fix
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kbd/files/kbd-2.0.4-vlock_configure_switch.patch25
-rw-r--r--sys-apps/kbd/kbd-2.0.4-r1.ebuild76
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-apps/kbd/files/kbd-2.0.4-vlock_configure_switch.patch b/sys-apps/kbd/files/kbd-2.0.4-vlock_configure_switch.patch
new file mode 100644
index 000000000000..c3f5b660cbd4
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-2.0.4-vlock_configure_switch.patch
@@ -0,0 +1,25 @@
+From f7f357ef079b6d185f340e716d7c72a98d82bad0 Mon Sep 17 00:00:00 2001
+From: Garry Filakhtov <filakhtov@gmail.com>
+Date: Fri, 20 Jul 2018 15:58:56 +0200
+Subject: [PATCH] configure.ac: Fix logic of vlock configure switch
+
+Downstream bug report: https://bugs.gentoo.org/661650
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 87eb63c..07098cf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -119,7 +119,7 @@ AM_CONDITIONAL(BUILD_LIBKEYMAP, test "$BUILD_LIBKEYMAP" = "yes")
+
+ AC_ARG_ENABLE(vlock,
+ AS_HELP_STRING(--disable-vlock, [do not build vlock]),
+- [VLOCK_PROG=no],[VLOCK_PROG=yes])
++ [VLOCK_PROG=$enableval],[VLOCK_PROG=yes])
+ AM_CONDITIONAL(VLOCK, test "$VLOCK_PROG" = "yes")
+
+ if test "$VLOCK_PROG" = "yes"; then
diff --git a/sys-apps/kbd/kbd-2.0.4-r1.ebuild b/sys-apps/kbd/kbd-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..fa8186612c07
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.0.4-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pam
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+
+RDEPEND="
+ app-arch/gzip
+ pam? (
+ !app-misc/vlock
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-vlock_configure_switch.patch"
+)
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ cd "${S}"/data/keymaps/i386 || die
+ mv dvorak/no.map dvorak/no-dvorak.map || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ docinto html
+ dodoc docs/doc/*.html
+ use pam && pamd_mimic_system vlock auth account
+}