summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 07:21:46 +0100
committerSam James <sam@gentoo.org>2022-10-28 07:36:30 +0100
commit391a9aa6b842be163119717cfe39b9960679e5cf (patch)
tree66006f2a834c3a81dd47d581299c5206e566220d /sys-apps
parentsys-process/latencytop: fix build with Clang (diff)
downloadgentoo-391a9aa6b842be163119717cfe39b9960679e5cf.tar.gz
gentoo-391a9aa6b842be163119717cfe39b9960679e5cf.tar.bz2
gentoo-391a9aa6b842be163119717cfe39b9960679e5cf.zip
sys-apps/findutils: use LFS (again); add missing dejagnu test dep
- Enable LFS (and time64) again, see ee514defae182ae2efb4e38cddacdbb523783093; not sure when it got lost. - Automagically runs more tests when dejagnu is installed, so BDEPEND on it for tests. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/findutils-4.9.0-r1.ebuild (renamed from sys-apps/findutils/findutils-4.9.0.ebuild)21
1 files changed, 15 insertions, 6 deletions
diff --git a/sys-apps/findutils/findutils-4.9.0.ebuild b/sys-apps/findutils/findutils-4.9.0-r1.ebuild
index 87b3edc629d7..520964bef11f 100644
--- a/sys-apps/findutils/findutils-4.9.0.ebuild
+++ b/sys-apps/findutils/findutils-4.9.0-r1.ebuild
@@ -18,12 +18,19 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
IUSE="nls selinux static test"
RESTRICT="!test? ( test )"
-RDEPEND="selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )"
-BDEPEND="nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-findutils )"
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-util/dejagnu
+ )
+ verify-sig? ( sec-keys/openpgp-keys-findutils )
+"
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -46,6 +53,8 @@ src_configure() {
append-ldflags -static
fi
+ append-lfs-flags
+
if [[ ${CHOST} == *-darwin* ]] ; then
# https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
# https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html