summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-05-03 07:43:36 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-05-03 07:54:54 -0500
commit43660bd641949589c5f95c4c644ebebe02219ef6 (patch)
tree44ad81c684c4a39bfe7578517197fa5fa17619ab /sys-apps
parentapp-emulation/docker-compose: Remove old (diff)
downloadgentoo-43660bd641949589c5f95c4c644ebebe02219ef6.tar.gz
gentoo-43660bd641949589c5f95c4c644ebebe02219ef6.tar.bz2
gentoo-43660bd641949589c5f95c4c644ebebe02219ef6.zip
sys-apps/usbredir: Apply a couple of upstream patches
... and call the resulting version usbredir-0.7.1_p20170503 Further, bump to EAPI 6, fix dependency Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/usbredir/Manifest1
-rw-r--r--sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
index 8b258f2c46fa..69ca4c763885 100644
--- a/sys-apps/usbredir/Manifest
+++ b/sys-apps/usbredir/Manifest
@@ -1,2 +1,3 @@
DIST usbredir-0.7.1.tar.bz2 329895 SHA256 407e9e27a1369f01264d5501ffbe88935ddd7d5de675f5835db05dc9c9ac56f3 SHA512 f8d26d59d5a530aa413fabe2402fbbd9662760453c2b4e83d34f2e5287c188114ea870f15ae1bc910297649986315be965f0d23d0a2b7b0cec2f207fc65d7598 WHIRLPOOL 8f85e7174e068fa1cffaa48e079d2348171fcc7907870eda3a5bef25c83dc6be5a468d19b84aee044fbc638fa8362aa63e98b372703065d3de3b4758ce20a310
+DIST usbredir-0.7.1_p20170503-patches.tar.xz 8120 SHA256 45b671997872170ccbdd111fd81d880a39f440fa2a997a22c6d2cf6f3f78c445 SHA512 b281d7a1ee191746e5fbe655b21c0cd9b2cf9cd69d5f28d91ab41de2d62a7f3c5c2a42f3f9c40c73d61a57d89423d996f4a779ebdff8f9d088030c2a4c2a24a7 WHIRLPOOL 9741309fdf10881708b964beecc10c08d0ed7073e4c2299a79b5a100c3c5cdf75ef3c87c68cc4d8f1e3d94d79e5fab5dcc63a983658e04fca53b5f625453ae08
DIST usbredir-0.7.tar.bz2 317216 SHA256 0a63a0712b5dc62be9cca44f97270fea5d1ec1fe7dde0c11dc74a01c8e2006aa SHA512 f615fc52f195c7159d16b551f6ecd9426f2aad64222f24b964fbd66fbf59498d80d4d5cf851cc1be9ddd27a9d962afa05970e1379f1ef02e8ac304235e82ad4a WHIRLPOOL 3f7ad0bcde1a109fcc9b32c23019d6078a1ea1c8d72998ce2d3b0c42278a953cfb739c74f21b5083c4e3da8f558ad0e60a82db540c3e1da1a89fd52d9208ff2b
diff --git a/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild b/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild
new file mode 100644
index 000000000000..87217034a408
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic
+
+MY_PV=${PV/_p*/}
+
+DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+SRC_URI="http://spice-space.org/download/${PN}/${PN}-${MY_PV}.tar.bz2
+ https://dev.gentoo.org/~tamiko/distfiles/${P}-patches.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+ "${S}_p20170503-patches"
+)
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/.libs/usbredirtestclient
+}