summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-15 12:35:36 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-15 12:48:50 +0100
commit5eafd8616730adc6677072d82c2c9e48c351b507 (patch)
tree902b0e62f733f0f4b027e99bfc9be19246f6c7b1 /sys-apps
parentx11-plugins/wmcpuwatch: initial import (diff)
downloadgentoo-5eafd8616730adc6677072d82c2c9e48c351b507.tar.gz
gentoo-5eafd8616730adc6677072d82c2c9e48c351b507.tar.bz2
gentoo-5eafd8616730adc6677072d82c2c9e48c351b507.zip
sys-apps/iproute2: Rev bump
Closes: https://bugs.gentoo.org/640654 Bug: https://bugzilla.redhat.com/1514963 Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/files/iproute2-4.14.1-fix-tc-actions.patch222
-rw-r--r--sys-apps/iproute2/iproute2-4.14.1-r2.ebuild146
2 files changed, 368 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-4.14.1-fix-tc-actions.patch b/sys-apps/iproute2/files/iproute2-4.14.1-fix-tc-actions.patch
new file mode 100644
index 000000000000..a8b7aaa9efe0
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-4.14.1-fix-tc-actions.patch
@@ -0,0 +1,222 @@
+From 3572e01a090a298e2f4c4f796bad6639b652e031 Mon Sep 17 00:00:00 2001
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Fri, 8 Dec 2017 11:18:07 +0100
+Subject: tc: util: Don't call NEXT_ARG_FWD() in __parse_action_control()
+
+Not all callers want parse_action_control*() to advance the
+arguments. For instance act_parse_police() does the argument
+advancing itself.
+
+Fixes: e67aba559581 ("tc: actions: add helpers to parse and print control actions")
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ tc/m_bpf.c | 1 +
+ tc/m_connmark.c | 1 +
+ tc/m_csum.c | 1 +
+ tc/m_gact.c | 10 +++++-----
+ tc/m_ife.c | 1 +
+ tc/m_mirred.c | 4 +++-
+ tc/m_nat.c | 1 +
+ tc/m_pedit.c | 1 +
+ tc/m_sample.c | 1 +
+ tc/m_skbedit.c | 1 +
+ tc/m_skbmod.c | 1 +
+ tc/m_tunnel_key.c | 1 +
+ tc/m_vlan.c | 1 +
+ tc/tc_util.c | 1 -
+ 14 files changed, 19 insertions(+), 7 deletions(-)
+
+diff --git a/tc/m_bpf.c b/tc/m_bpf.c
+index 1c1f71c..576f69c 100644
+--- a/tc/m_bpf.c
++++ b/tc/m_bpf.c
+@@ -129,6 +129,7 @@ opt_bpf:
+
+ parse_action_control_dflt(&argc, &argv, &parm.action,
+ false, TC_ACT_PIPE);
++ NEXT_ARG_FWD();
+
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+diff --git a/tc/m_connmark.c b/tc/m_connmark.c
+index 37d7185..47c7a8c 100644
+--- a/tc/m_connmark.c
++++ b/tc/m_connmark.c
+@@ -82,6 +82,7 @@ parse_connmark(struct action_util *a, int *argc_p, char ***argv_p, int tca_id,
+ }
+
+ parse_action_control_dflt(&argc, &argv, &sel.action, false, TC_ACT_PIPE);
++ NEXT_ARG_FWD();
+
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+diff --git a/tc/m_csum.c b/tc/m_csum.c
+index 7b15673..e1352c0 100644
+--- a/tc/m_csum.c
++++ b/tc/m_csum.c
+@@ -124,6 +124,7 @@ parse_csum(struct action_util *a, int *argc_p,
+ }
+
+ parse_action_control_dflt(&argc, &argv, &sel.action, false, TC_ACT_OK);
++ NEXT_ARG_FWD();
+
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+diff --git a/tc/m_gact.c b/tc/m_gact.c
+index e7d91da..b30b042 100644
+--- a/tc/m_gact.c
++++ b/tc/m_gact.c
+@@ -87,14 +87,13 @@ parse_gact(struct action_util *a, int *argc_p, char ***argv_p,
+ if (argc < 0)
+ return -1;
+
+-
+- if (matches(*argv, "gact") == 0) {
+- argc--;
+- argv++;
+- } else if (parse_action_control(&argc, &argv, &p.action, false) == -1) {
++ if (matches(*argv, "gact") != 0 &&
++ parse_action_control(&argc, &argv, &p.action, false) == -1) {
+ usage(); /* does not return */
+ }
+
++ NEXT_ARG_FWD();
++
+ #ifdef CONFIG_GACT_PROB
+ if (argc > 0) {
+ if (matches(*argv, "random") == 0) {
+@@ -114,6 +113,7 @@ parse_gact(struct action_util *a, int *argc_p, char ***argv_p,
+ if (parse_action_control(&argc, &argv,
+ &pp.paction, false) == -1)
+ usage();
++ NEXT_ARG_FWD();
+ if (get_u16(&pp.pval, *argv, 10)) {
+ fprintf(stderr,
+ "Illegal probability val 0x%x\n",
+diff --git a/tc/m_ife.c b/tc/m_ife.c
+index 205efc9..4647f6a 100644
+--- a/tc/m_ife.c
++++ b/tc/m_ife.c
+@@ -159,6 +159,7 @@ static int parse_ife(struct action_util *a, int *argc_p, char ***argv_p,
+
+ parse_action_control_dflt(&argc, &argv, &p.action, false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_mirred.c b/tc/m_mirred.c
+index 3870d3a..aa7ce6d 100644
+--- a/tc/m_mirred.c
++++ b/tc/m_mirred.c
+@@ -202,8 +202,10 @@ parse_direction(struct action_util *a, int *argc_p, char ***argv_p,
+ }
+
+
+- if (p.eaction == TCA_EGRESS_MIRROR || p.eaction == TCA_INGRESS_MIRROR)
++ if (p.eaction == TCA_EGRESS_MIRROR || p.eaction == TCA_INGRESS_MIRROR) {
+ parse_action_control(&argc, &argv, &p.action, false);
++ NEXT_ARG_FWD();
++ }
+
+ if (argc) {
+ if (iok && matches(*argv, "index") == 0) {
+diff --git a/tc/m_nat.c b/tc/m_nat.c
+index 1e4ff51..f5de4d4 100644
+--- a/tc/m_nat.c
++++ b/tc/m_nat.c
+@@ -116,6 +116,7 @@ parse_nat(struct action_util *a, int *argc_p, char ***argv_p, int tca_id, struct
+
+ parse_action_control_dflt(&argc, &argv, &sel.action, false, TC_ACT_OK);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_pedit.c b/tc/m_pedit.c
+index 26549ee..dc57f14 100644
+--- a/tc/m_pedit.c
++++ b/tc/m_pedit.c
+@@ -672,6 +672,7 @@ int parse_pedit(struct action_util *a, int *argc_p, char ***argv_p, int tca_id,
+
+ parse_action_control_dflt(&argc, &argv, &sel.sel.action, false, TC_ACT_OK);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_sample.c b/tc/m_sample.c
+index ff5ee6b..31774c0 100644
+--- a/tc/m_sample.c
++++ b/tc/m_sample.c
+@@ -100,6 +100,7 @@ static int parse_sample(struct action_util *a, int *argc_p, char ***argv_p,
+
+ parse_action_control_dflt(&argc, &argv, &p.action, false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_skbedit.c b/tc/m_skbedit.c
+index aa374fc..c41a7bb 100644
+--- a/tc/m_skbedit.c
++++ b/tc/m_skbedit.c
+@@ -123,6 +123,7 @@ parse_skbedit(struct action_util *a, int *argc_p, char ***argv_p, int tca_id,
+ parse_action_control_dflt(&argc, &argv, &sel.action,
+ false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_skbmod.c b/tc/m_skbmod.c
+index 561b73f..bc268df 100644
+--- a/tc/m_skbmod.c
++++ b/tc/m_skbmod.c
+@@ -124,6 +124,7 @@ static int parse_skbmod(struct action_util *a, int *argc_p, char ***argv_p,
+
+ parse_action_control_dflt(&argc, &argv, &p.action, false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_tunnel_key.c b/tc/m_tunnel_key.c
+index 1cdd035..2dc9187 100644
+--- a/tc/m_tunnel_key.c
++++ b/tc/m_tunnel_key.c
+@@ -175,6 +175,7 @@ static int parse_tunnel_key(struct action_util *a, int *argc_p, char ***argv_p,
+ parse_action_control_dflt(&argc, &argv, &parm.action,
+ false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/m_vlan.c b/tc/m_vlan.c
+index 161759f..edae0d1 100644
+--- a/tc/m_vlan.c
++++ b/tc/m_vlan.c
+@@ -131,6 +131,7 @@ static int parse_vlan(struct action_util *a, int *argc_p, char ***argv_p,
+ parse_action_control_dflt(&argc, &argv, &parm.action,
+ false, TC_ACT_PIPE);
+
++ NEXT_ARG_FWD();
+ if (argc) {
+ if (matches(*argv, "index") == 0) {
+ NEXT_ARG();
+diff --git a/tc/tc_util.c b/tc/tc_util.c
+index 1887905..ee9a70a 100644
+--- a/tc/tc_util.c
++++ b/tc/tc_util.c
+@@ -586,7 +586,6 @@ static int __parse_action_control(int *argc_p, char ***argv_p, int *result_p,
+ }
+ result |= jump_cnt;
+ }
+- NEXT_ARG_FWD();
+ *argc_p = argc;
+ *argv_p = argv;
+ *result_p = result;
+--
+cgit v1.1
+
diff --git a/sys-apps/iproute2/iproute2-4.14.1-r2.ebuild b/sys-apps/iproute2/iproute2-4.14.1-r2.ebuild
new file mode 100644
index 000000000000..ab9012f964c5
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-4.14.1-r2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://kernel/linux/utils/net/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="atm berkdb +iptables ipv6 minimal selinux"
+
+# We could make libmnl optional, but it's tiny, so eh
+RDEPEND="
+ !net-misc/arpd
+ !minimal? ( net-libs/libmnl virtual/libelf )
+ iptables? ( >=net-firewall/iptables-1.4.20:= )
+ berkdb? ( sys-libs/db:= )
+ atm? ( net-dialup/linux-atm )
+ selinux? ( sys-libs/libselinux )
+"
+# We require newer linux-headers for ipset support #549948 and some defines #553876
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ iptables? ( virtual/pkgconfig )
+ >=sys-devel/bison-2.4
+ sys-devel/flex
+ >=sys-kernel/linux-headers-3.16
+ elibc_glibc? ( >=sys-libs/glibc-2.7 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
+ "${FILESDIR}"/${P}-fix-tc-actions.patch
+)
+
+src_prepare() {
+ if ! use ipv6 ; then
+ PATCHES+=(
+ "${FILESDIR}"/${PN}-4.11.0-no-ipv6.patch #326849
+ )
+ fi
+
+ default
+
+ sed -i \
+ -e '/^CC :\?=/d' \
+ -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
+ -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ -e "/^WFLAGS/s:-Werror::" \
+ -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
+ Makefile || die
+
+ # Use /run instead of /var/run.
+ sed -i \
+ -e 's:/var/run:/run:g' \
+ include/namespace.h \
+ man/man8/ip-netns.8 || die
+
+ # build against system headers
+ rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
+ sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
+
+ use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile
+}
+
+src_configure() {
+ tc-export AR CC PKG_CONFIG
+
+ # This sure is ugly. Should probably move into toolchain-funcs at some point.
+ local setns
+ pushd "${T}" >/dev/null
+ printf '#include <sched.h>\nint main(){return setns(0, 0);}\n' > test.c
+ ${CC} ${CFLAGS} ${CPPFLAGS} -D_GNU_SOURCE ${LDFLAGS} test.c >&/dev/null && setns=y || setns=n
+ echo 'int main(){return 0;}' > test.c
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} test.c -lresolv >&/dev/null || sed -i '/^LDLIBS/s:-lresolv::' "${S}"/Makefile
+ popd >/dev/null
+
+ # run "configure" script first which will create "config.mk"...
+ default
+
+ # ...now switch on/off requested features via USE flags
+ cat <<-EOF >> config.mk
+ TC_CONFIG_ATM := $(usex atm y n)
+ TC_CONFIG_XT := $(usex iptables y n)
+ TC_CONFIG_NO_XT := $(usex iptables n y)
+ # We've locked in recent enough kernel headers #549948
+ TC_CONFIG_IPSET := y
+ HAVE_BERKELEY_DB := $(usex berkdb y n)
+ HAVE_MNL := $(usex minimal n y)
+ HAVE_ELF := $(usex minimal n y)
+ HAVE_SELINUX := $(usex selinux y n)
+ IP_CONFIG_SETNS := ${setns}
+ # Use correct iptables dir, #144265 #293709
+ IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
+ EOF
+}
+
+src_install() {
+ if use minimal ; then
+ into /
+ dosbin tc/tc
+ dobin ip/ip
+ return 0
+ fi
+
+ emake \
+ DESTDIR="${D}" \
+ LIBDIR="${EPREFIX%/}"/$(get_libdir) \
+ SBINDIR="${EPREFIX%/}"/sbin \
+ CONFDIR="${EPREFIX%/}"/etc/iproute2 \
+ DOCDIR="${EPREFIX%/}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX%/}"/usr/share/man \
+ ARPDDIR="${EPREFIX%/}"/var/lib/arpd \
+ install
+
+ dodir /bin
+ mv "${ED%/}"/{s,}bin/ip || die #330115
+
+ dolib.a lib/libnetlink.a
+ insinto /usr/include
+ doins include/libnetlink.h
+ # This local header pulls in a lot of linux headers it
+ # doesn't directly need. Delete this header that requires
+ # linux-headers-3.8 until that goes stable. #467716
+ sed -i '/linux\/netconf.h/d' "${ED%/}"/usr/include/libnetlink.h || die
+
+ if use berkdb ; then
+ dodir /var/lib/arpd
+ # bug 47482, arpd doesn't need to be in /sbin
+ dodir /usr/bin
+ mv "${ED%/}"/sbin/arpd "${ED%/}"/usr/bin/ || die
+ fi
+}