summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-01-12 13:02:18 -0600
committerBen Kohler <bkohler@gentoo.org>2023-01-12 14:47:04 -0600
commit6fe8452d2918daad4bcea1002bbe48afcdfc655f (patch)
treed2878690f882b1f6691d5c954e2229921fad5e6a /sys-apps
parentmedia-sound/kid3: add 3.9.3 (diff)
downloadgentoo-6fe8452d2918daad4bcea1002bbe48afcdfc655f.tar.gz
gentoo-6fe8452d2918daad4bcea1002bbe48afcdfc655f.tar.bz2
gentoo-6fe8452d2918daad4bcea1002bbe48afcdfc655f.zip
sys-apps/hwinfo: add 22.2
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-22.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index 1096d4aeb0ad..46beec5cc53d 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,2 +1,3 @@
DIST hwinfo-21.80-1.1.src.rpm 968192 BLAKE2B a11a1060137ff89504963c01c4129dcac93e8eea9747ea20272763f648068e8b4fb3f1c31ae761664b1b1ffedf32971b3b27804f125473f0367cc6eed03751bf SHA512 7bf64d9ee6b2381c43ffb22dc5623c8a8ed05c26b4e154c3093a9cb255779a1d482c18cd085b272ce619249743f1c43989337bed142685b4d6c634f4551893ee
DIST hwinfo-22.1-1.1.src.rpm 969862 BLAKE2B f295c941804d3264b45739fa3d1801c2e31d67ce50f49caafeaae5a4dbf809fcfb9b44eaefee6ac9c61f54c1639fe1cf7ba710a9bbae5c4adbc7b5740e706796 SHA512 83f5d2dc78dfb10987a57a52f194d5db38ec66e73daad8fdf08386b131cf862b6c7bc3404451550f91363bb3d4090e67ca36aeba001f506075e55721004f2759
+DIST hwinfo-22.2-1.1.src.rpm 1063003 BLAKE2B 9c786c7279fea0cbad17399f2f7360fdbb29f597277437edc63c2ca732b54c79f2ba53393a2258c7aa45e79588aa5d133e24f76744d5b62dd6072122432b4708 SHA512 88c60f551891685caf4e13e78eebf8e1023f168ef3542c319b7f9509ef5abd1c1c9acfa69e3af20ea9151e20682fa1e0c26042576bb9aca8ee7c2c71d5d5a60d
diff --git a/sys-apps/hwinfo/hwinfo-22.2.ebuild b/sys-apps/hwinfo/hwinfo-22.2.ebuild
new file mode 100644
index 000000000000..a1d640170ff5
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-22.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}