summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-08-05 08:39:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-08-05 08:39:57 +0200
commit700f2ea5e9b992a67ac720f8e040201d4002468f (patch)
treef606add78b24f94a1ebc79cddb1e4350bd90c1c2 /sys-apps
parentsys-fs/exfatprogs: Initial commit (diff)
downloadgentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.tar.gz
gentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.tar.bz2
gentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.zip
sys-apps/ethtool: Bump to version 5.8
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.8.ebuild22
-rw-r--r--sys-apps/ethtool/files/ethtool-5.8-avoid_bashisms.patch29
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index 3166c8e3d1e7..35d182609148 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,3 +1,4 @@
DIST ethtool-5.4.tar.xz 239288 BLAKE2B 8c8b2bee53fe3e71510684ca7c6f64153cb6f1c5ebe44cd4d1dc351885d2d9957eb206a96bda9efadb5faa0e15a3f0ba07923d7e29b27694e3e3f605151a940d SHA512 c7bfe7eae2ba207d710716274e9f5ae275c57d0bebc0a9acb95677125e64f1b42ef610032011fb59894aab46973988bad40fddbc5ccc238893e7da66f913255b
DIST ethtool-5.6.tar.xz 281084 BLAKE2B 1fecc52e9031a3d13cbe6b3c508ebd7fc6dc03b02d4126b3ddd9ef40eedbef151b66f52e80b6570d45ebba09437b587124d2c22817da7d4f3658bd1ff1d3c8a1 SHA512 9308f8e4a297d842a7a5a51419e408951e669da1f58cb1eed41f52be4cd2f32f811d1d19e9bee59d8297938a6d5a4abff2b9bbf789d0c49ed5074a78826d3199
DIST ethtool-5.7.tar.xz 283048 BLAKE2B 1f265ea452ec0d37b4bd4bb4e602a27d2d26144d750940b2c61638524626fffb59c3fbf054472e31ff755260d7cce8f6cdc31ef74a512a3656830b546b4bbe6d SHA512 195e24c48201412e0eaad7d7ca4e530c3a8cf50f3518cfe49d299fd091cf9198007c5d23be95109c735ceb2ccad37ac9f2e9cde0fb36ea426ab17b1dd064d4a9
+DIST ethtool-5.8.tar.xz 299416 BLAKE2B ea7433205eba831b6ba56e140c73cfe283cc5dc56ced963414a017b0d6b6fbde9d0195ff64ebdc060351e5e9844af8beb8f00f7e04d76b04f958b166cda7e589 SHA512 5eada909f82573ad93bc5476e6f8d50f68ce2c9948558877eb6ace8dc17aee895b2f27343592f5f23eaef0e0fc70b5f776f76e75d9614bab305a2819ca82370e
diff --git a/sys-apps/ethtool/ethtool-5.8.ebuild b/sys-apps/ethtool/ethtool-5.8.ebuild
new file mode 100644
index 000000000000..49fc0d567fc9
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+netlink"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+
+PATCHES=( "${FILESDIR}/${PN}-5.8-avoid_bashisms.patch" )
+
+src_configure() {
+ econf $(use_enable netlink)
+}
diff --git a/sys-apps/ethtool/files/ethtool-5.8-avoid_bashisms.patch b/sys-apps/ethtool/files/ethtool-5.8-avoid_bashisms.patch
new file mode 100644
index 000000000000..9cd9fd86fb70
--- /dev/null
+++ b/sys-apps/ethtool/files/ethtool-5.8-avoid_bashisms.patch
@@ -0,0 +1,29 @@
+Running this script with dash results in an endless loop spitting out this:
+
+ ./test-driver: 62: [: --test-name: unexpected operator
+ ./test-driver: 78: [[: not found
+
+This is caused by two bashisms which are being fixed by the below patch
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- ethtool-5.8/test-driver
++++ ethtool-5.8/test-driver
+@@ -59,7 +59,7 @@
+ while test $# -gt 1; do
+ arg=${1%=*}
+ val=${1#*=}
+- if [ $arg == $val ]; then
++ if [ $arg = $val ]; then
+ val=$2
+ shift
+ fi
+@@ -75,7 +75,7 @@
+ --) break;;
+ -*) usage_error "invalid option: '$1'";;
+ esac
+- [[ $arg != $val ]] && shift
++ [ $arg != $val ] && shift
+ done
+
+ missing_opts=