summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-10 04:37:11 +0000
committerSam James <sam@gentoo.org>2021-12-10 04:37:11 +0000
commit7bc1125e5aaf936b572752dd43cef7d489f81bef (patch)
treeca736e7a4cfba3adb9f9ab28f3fb18e7308a5968 /sys-apps
parentmedia-libs/glfw: add 3.3.6 (diff)
downloadgentoo-7bc1125e5aaf936b572752dd43cef7d489f81bef.tar.gz
gentoo-7bc1125e5aaf936b572752dd43cef7d489f81bef.tar.bz2
gentoo-7bc1125e5aaf936b572752dd43cef7d489f81bef.zip
sys-apps/hwdata: add 0.354
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.354.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index a515ed8163e7..ddc6cb5044b6 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1 +1,2 @@
DIST hwdata-0.353.tar.gz 2206215 BLAKE2B e1c30d7d486a2f03eb8b59dfc12544a5e5a988295d5dc220e2d6a344991c62d8ded0e8e71a8b0907fb9fb7fe0bac8528386cc4665c903362db6ed6f0a6985b94 SHA512 f4bdea533a1cdf406d065da6a684b131b30f6a0b8fb791418d54b756c9297da981a8e25e128ef97af50ae88553e1473dba17a29c11a15490065faf9bf2dcd0d4
+DIST hwdata-0.354.tar.gz 2212834 BLAKE2B 5df04fd6069e131be7195b515f4f7273e28030d46823fa3054371f9afde4eb9976df2663bc7d31d056cb718a479630676f05459064decd59914f3a69bcfb03f1 SHA512 07bbe5137f35c0402029e066e90a29da1ca95faa6996a192b1f9ac00568e5020cc540b642ad2b22b25c2cfa0d7e4c2d7b80c9978ca0cd091691d8f1cf2933915
diff --git a/sys-apps/hwdata/hwdata-0.354.ebuild b/sys-apps/hwdata/hwdata-0.354.ebuild
new file mode 100644
index 000000000000..e6dfcf28e7a4
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.354.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+ echo "${conf[@]}" >&2
+ "${conf[@]}" || die
+}