summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-03 14:44:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-03 14:48:38 +0200
commit87c9ec0352732419fcb18bdf49334d037f5153e7 (patch)
treefc8c17fa030a859f748390a61ae1f44ccc812842 /sys-apps
parentnet-irc/polari: bump to 3.38.1 (diff)
downloadgentoo-87c9ec0352732419fcb18bdf49334d037f5153e7.tar.gz
gentoo-87c9ec0352732419fcb18bdf49334d037f5153e7.tar.bz2
gentoo-87c9ec0352732419fcb18bdf49334d037f5153e7.zip
sys-apps/texinfo: Bump to version 6.8
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-6.8.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 330cba608891..fad5e0194c83 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1 +1,2 @@
DIST texinfo-6.7.tar.gz 9027808 BLAKE2B ac9a47ae98f27ae55ea1844c74ead6fba256635a56e7a226a1bbdd9ee9ab33565ff8cc7a874410afe6463741285c8fcfd8ff835ae2802009e2d0758405559140 SHA512 a52aaa2f0113c6f14b3cb94fbf7191770017ff6ce2016292770831279cfbb898c2f7f720adee620e08d9d80a9505df89a689ba0c25e92f6579b28b075f7b8ee2
+DIST texinfo-6.8.tar.gz 10119420 BLAKE2B df9dc1698e7bb4f7c97ba4d44b08631502e3f997b91169ae64161b69701fbb0f85c82295ef6867e716a0addfd7c5677e14079645b167bd74933a0153fee92200 SHA512 f46dfb1c0f324a9c54959a8f256f0dcb8aaa59caccb0f027a5ee39a173b6e51a31a488f9d787707e7aa8401a439b2a01a1f3022dbae24ef377a1c021c1ebeb37
diff --git a/sys-apps/texinfo/texinfo-6.8.ebuild b/sys-apps/texinfo/texinfo-6.8.ebuild
new file mode 100644
index 000000000000..3f25e5592134
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ standalone? ( dev-lang/perl )
+ !standalone? (
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+ local myeconfargs=( $(use_enable nls) )
+
+ if use standalone ; then
+ myeconfargs+=(
+ --without-external-libintl-perl
+ --without-external-Unicode-EastAsianWidth
+ --without-external-Text-Unidecode
+ --disable-perl-xs
+ )
+ else
+ myeconfargs+=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ --enable-perl-xs
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}