summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-06-28 22:37:10 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-06-28 22:37:27 -0700
commit8fb2b4ce43a4f356ff6db728fde15c0a36e34642 (patch)
tree8227febfb1b490aff16e5745f926b761ee9fbd9c /sys-apps
parentnet-nds/nsscache: bump for py3 (diff)
downloadgentoo-8fb2b4ce43a4f356ff6db728fde15c0a36e34642.tar.gz
gentoo-8fb2b4ce43a4f356ff6db728fde15c0a36e34642.tar.bz2
gentoo-8fb2b4ce43a4f356ff6db728fde15c0a36e34642.zip
sys-apps/x86info: bump for py3
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/x86info/Manifest1
-rw-r--r--sys-apps/x86info/x86info-1.30-r1.ebuild72
-rw-r--r--sys-apps/x86info/x86info-1.30_p20190617.ebuild73
3 files changed, 146 insertions, 0 deletions
diff --git a/sys-apps/x86info/Manifest b/sys-apps/x86info/Manifest
index bcc650214b00..3fa8bb65f0ee 100644
--- a/sys-apps/x86info/Manifest
+++ b/sys-apps/x86info/Manifest
@@ -1 +1,2 @@
DIST x86info-1.30.tgz 95727 BLAKE2B 6e9e345c6b4d05d4a137b898f1cc8a31e901b25b8a3822c06c103298e2ee60c6fada8e1fc314a5fcec04618b9a8a9ce05a4e631dbf9f03a24c5349f13d1e2301 SHA512 0b4c9f1be83a737aa26ec14d239d09465608fcf542766ef5b8634d2fe08f75857c0d2bd1969d971ab4b0d55cd3aa3e4e5f58b3b2865865aa68fd751377672e5f
+DIST x86info-1.30_p20190617.tar.gz 85913 BLAKE2B e19e5fd797617499c64e75522f0fd030beaa335a6ba9afd29cbb79fd67313a2e57236d1ad8817bf91f0131faf667ba88ac0945ff25301ba8806912979f094ea3 SHA512 352e2b00578dc54b8d5ee32f09f327ab6a23e6ab4743882ca78a5a5ec1a04ceed8780228ffbda34f84ebb02c7cb850002a686929726feac90c8083044f479bd6
diff --git a/sys-apps/x86info/x86info-1.30-r1.ebuild b/sys-apps/x86info/x86info-1.30-r1.ebuild
new file mode 100644
index 000000000000..5a09ba8a8e78
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.30-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4..8} )
+
+inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils:="
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}"
+
+CONFIG_CHECK="~MTRR ~X86_CPUID"
+
+PATCHES=(
+ "${FILESDIR}"/1.21-pic.patch
+ "${FILESDIR}"/${PN}-1.24-pic.patch #270388
+ "${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
+ "${FILESDIR}"/${PN}-1.30-fix-build-system.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # These flags taken from the 1.29 ebuild
+ append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
+ -Wdeclaration-after-statement -Wredundant-decls
+ append-ldflags -Wl,-z,relro,-z,now
+
+ tc-export CC
+}
+
+src_compile() {
+ emake x86info lsmsr
+}
+
+src_install() {
+ dobin x86info lsmsr
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ einstalldocs
+ doman x86info.1 lsmsr.8
+
+ dodoc -r results
+}
+
+pkg_preinst() {
+ if [[ -a "${EROOT}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info ]]; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${EROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a "${EROOT}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info.conf ]]; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${EROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}
diff --git a/sys-apps/x86info/x86info-1.30_p20190617.ebuild b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
new file mode 100644
index 000000000000..d8a3b48dfadf
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4..8} )
+
+inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+# Upstream stopped versioned releases entirely
+COMMIT="8ea5ed19fae1d209eba9257171a10f7afd474618"
+SRC_URI="https://github.com/kernelslacker/x86info/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils:="
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}"
+
+CONFIG_CHECK="~MTRR ~X86_CPUID"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=(
+ #"${FILESDIR}"/1.21-pic.patch
+ "${FILESDIR}"/${PN}-1.24-pic.patch #270388
+ #"${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
+ #"${FILESDIR}"/${PN}-1.30-fix-build-system.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # These flags taken from the 1.29 ebuild
+ append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
+ -Wdeclaration-after-statement -Wredundant-decls
+ append-ldflags -Wl,-z,relro,-z,now
+
+ tc-export CC
+}
+
+src_compile() {
+ emake x86info
+}
+
+src_install() {
+ dobin x86info
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ einstalldocs
+ doman x86info.1
+}
+
+pkg_preinst() {
+ if [[ -a "${EROOT}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info ]]; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${EROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a "${EROOT}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info.conf ]]; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${EROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}