summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-01 20:30:50 +0000
committerJason Zaman <perfinion@gentoo.org>2020-09-14 20:40:27 -0700
commit8fcab3b2947b4db43b7af479520e51f7db88b63e (patch)
tree00d9124023e007a03b5d4ac0779dabc3d7a24af0 /sys-apps
parentsys-apps/semodule-utils: Version bump to 3.1. (diff)
downloadgentoo-8fcab3b2947b4db43b7af479520e51f7db88b63e.tar.gz
gentoo-8fcab3b2947b4db43b7af479520e51f7db88b63e.tar.bz2
gentoo-8fcab3b2947b4db43b7af479520e51f7db88b63e.zip
sys-apps/secilc: Version bump to 3.1.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-3.1.ebuild44
-rw-r--r--sys-apps/secilc/secilc-9999.ebuild6
3 files changed, 48 insertions, 3 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index 7cbc7ab1d415..771d092acdbd 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1,2 +1,3 @@
DIST secilc-2.9.tar.gz 175885 BLAKE2B 0a5fd0adb70ce80574148ac035dcb8c5c80f6779a6a0c696eaba26cb6c4441e58eb161600034102dcb34c87099357bfc66015d245cf2fd49b56e65d782fc8aac SHA512 c552ce65fc23bef1a93b3dc485369d64ad19a3f30707b95d0dd488d1766ab9f5e75884b79e6464997eaafee119193a1fdd5ff8228aee0fa902e426eefa14a4ee
DIST secilc-3.0.tar.gz 176060 BLAKE2B dcceaa72f3e34777f0d4a6a05de073e4f2dc53b7577c2a52d5b5ab5e10d394ad85817985e683c9af241cf6bdc9a549d52142477281000e19ff66063f440b4b3a SHA512 e82d973c99b95a7f34060ce10a7f39802c3d6d428a52992efd8551da7bceafbdf9f81262d9aa2ad9d22a0704959de525c5a2de21fd96651277fab433ef340225
+DIST secilc-3.1.tar.gz 176631 BLAKE2B e79818580d2a788d672574ebd77349f0c59b678d2be628479f517412ca876fa225ba0dd63ef3200ed15ff693cd5f4cb4ff537d81666fef3a008ba4b3a7577e0c SHA512 79e3e4910178af49ea164d620aa997adb21dd18581c054a4023dd9116ec9dd203bd12989ef308aa1d253b47fcd251ee2b99c26e143d1db3de22a7f374ff38e0b
diff --git a/sys-apps/secilc/secilc-3.1.ebuild b/sys-apps/secilc/secilc-3.1.ebuild
new file mode 100644
index 000000000000..db36c3ca9f49
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20200710"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}
diff --git a/sys-apps/secilc/secilc-9999.ebuild b/sys-apps/secilc/secilc-9999.ebuild
index d920dbb0436b..db36c3ca9f49 100644
--- a/sys-apps/secilc/secilc-9999.ebuild
+++ b/sys-apps/secilc/secilc-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit toolchain-funcs
MY_P="${P//_/-}"
-MY_RELEASEDATE="20191204"
+MY_RELEASEDATE="20200710"
SEPOL_VER="${PV}"