summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-24 10:26:59 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-24 10:26:59 +0100
commit8ff0f0fe5eafd4e857eb37cc42e841221f4e0230 (patch)
tree02f2b706002bd09e5e53fcb261c9fb1e6dd4e44f /sys-apps
parentdev-java/typesafe-config: Stabilize 1.3.0-r3 x86, #831955 (diff)
downloadgentoo-8ff0f0fe5eafd4e857eb37cc42e841221f4e0230.tar.gz
gentoo-8ff0f0fe5eafd4e857eb37cc42e841221f4e0230.tar.bz2
gentoo-8ff0f0fe5eafd4e857eb37cc42e841221f4e0230.zip
sys-apps/hwids: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/Manifest1
-rw-r--r--sys-apps/hwids/hwids-20210613-r2.ebuild93
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild95
-rw-r--r--sys-apps/hwids/metadata.xml21
4 files changed, 0 insertions, 210 deletions
diff --git a/sys-apps/hwids/Manifest b/sys-apps/hwids/Manifest
deleted file mode 100644
index 3a7943079186..000000000000
--- a/sys-apps/hwids/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST hwids-20210613.tar.gz 3867741 BLAKE2B 64c4b0a83058a2052f7b132241008a3cc75452e93a9a57a9159c357c23fd09ee256abc2b94e700b5d8e8bd4e231ae12932d2c2f32fb03853207739cb3387047d SHA512 4568f6b8c0ca80ec772bd2785d4dc169d1d13a721472a15399158d9a7f31abbe414c5c8cfdf1a3b81cce4e33742a4b6e005e97e3e907643d0afdc8e953624fea
diff --git a/sys-apps/hwids/hwids-20210613-r2.ebuild b/sys-apps/hwids/hwids-20210613-r2.ebuild
deleted file mode 100644
index 1918ad974880..000000000000
--- a/sys-apps/hwids/hwids-20210613-r2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 2012-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit udev
-
-DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
-HOMEPAGE="https://github.com/gentoo/hwids"
-if [[ ${PV} == 99999999 ]]; then
- PYTHON_COMPAT=( python3_{6..9} )
- inherit git-r3 python-any-r1
- EGIT_REPO_URI="https://github.com/gentoo/hwids.git"
-else
- SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="|| ( GPL-2 BSD ) public-domain"
-SLOT="0"
-IUSE="+net +pci systemd +udev +usb"
-REQUIRED_USE="systemd? ( udev )"
-
-RDEPEND="
- systemd? ( sys-apps/systemd[hwdb(+)] )
- udev? ( virtual/udev )
-"
-
-if [[ ${PV} == 99999999 ]]; then
- BDEPEND="
- net-misc/curl
- udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
- "
- python_check_deps() {
- if use udev; then
- has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
- fi
- }
-else
- S=${WORKDIR}/hwids-${P}
-fi
-
-pkg_setup() {
- :
-}
-
-src_unpack() {
- if [[ ${PV} == 99999999 ]]; then
- git-r3_src_unpack
- cd "${S}" || die
- emake fetch
- else
- default
- fi
-}
-
-src_prepare() {
- default
- sed -i -e '/udevadm hwdb/d' Makefile || die
-}
-
-_emake() {
- emake \
- NET=$(usex net) \
- PCI=$(usex pci) \
- UDEV=$(usex udev) \
- USB=$(usex usb) \
- "$@"
-}
-
-src_compile() {
- if [[ ${PV} == 99999999 ]] && use udev; then
- python_setup
- _emake udev-hwdb
- fi
- _emake
-}
-
-src_install() {
- _emake install \
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
- MISCDIR="${EPREFIX}/usr/share/misc" \
- HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
- DESTDIR="${D}"
-}
-
-pkg_postinst() {
- if use systemd; then
- systemd-hwdb --root="${ROOT}" update
- elif use udev; then
- udevadm hwdb --update --root="${ROOT}"
- fi
-}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
deleted file mode 100644
index a4f483a3048a..000000000000
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 2012-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit udev
-
-DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
-HOMEPAGE="https://github.com/gentoo/hwids"
-if [[ ${PV} == 99999999 ]]; then
- PYTHON_COMPAT=( python3_{6..9} )
- inherit git-r3 python-any-r1
- EGIT_REPO_URI="https://github.com/gentoo/hwids.git"
-else
- SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="|| ( GPL-2 BSD ) public-domain"
-SLOT="0"
-IUSE="+net +pci systemd +udev +usb"
-REQUIRED_USE="systemd? ( udev )"
-
-RDEPEND="
- systemd? ( sys-apps/systemd[hwdb(+)] )
- udev? ( virtual/udev )
-"
-
-if [[ ${PV} == 99999999 ]]; then
- BDEPEND="
- dev-vcs/git-tools
- net-misc/curl
- udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
- "
- python_check_deps() {
- if use udev; then
- has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
- fi
- }
-else
- S=${WORKDIR}/hwids-${P}
-fi
-
-pkg_setup() {
- :
-}
-
-src_unpack() {
- if [[ ${PV} == 99999999 ]]; then
- git-r3_src_unpack
- cd "${S}" || die
- git-restore-mtime || die
- emake fetch
- else
- default
- fi
-}
-
-src_prepare() {
- default
- sed -i -e '/udevadm hwdb/d' Makefile || die
-}
-
-_emake() {
- emake \
- NET=$(usex net) \
- PCI=$(usex pci) \
- UDEV=$(usex udev) \
- USB=$(usex usb) \
- "$@"
-}
-
-src_compile() {
- if [[ ${PV} == 99999999 ]] && use udev; then
- python_setup
- _emake udev-hwdb
- fi
- _emake
-}
-
-src_install() {
- _emake install \
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
- MISCDIR="${EPREFIX}/usr/share/misc" \
- HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
- DESTDIR="${D}"
-}
-
-pkg_postinst() {
- if use systemd; then
- systemd-hwdb --root="${ROOT}" update
- elif use udev; then
- udevadm hwdb --update --root="${ROOT}"
- fi
-}
diff --git a/sys-apps/hwids/metadata.xml b/sys-apps/hwids/metadata.xml
deleted file mode 100644
index dfe5f36d6fa1..000000000000
--- a/sys-apps/hwids/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
- </maintainer>
- <maintainer type="person">
- <email>floppym@gentoo.org</email>
- </maintainer>
- <stabilize-allarches/>
- <use>
- <flag name="net">Install the oui.txt and iab.txt databases</flag>
- <flag name="pci">Install the pci.ids database</flag>
- <flag name="usb">Install the usb.ids database</flag>
- <flag name="udev">Install hwdb.d rules for udev</flag>
- </use>
- <upstream>
- <remote-id type="github">gentoo/hwids</remote-id>
- </upstream>
-</pkgmetadata>