summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 11:31:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:38 +0200
commit9731ed249f08c6bc74551c749733fe5d5146645e (patch)
treeba707d4df47af29ec83eb2122de995d2d5efd742 /sys-apps
parentdev-python/snakeoil: Restore last good infra version (diff)
downloadgentoo-9731ed249f08c6bc74551c749733fe5d5146645e.tar.gz
gentoo-9731ed249f08c6bc74551c749733fe5d5146645e.tar.bz2
gentoo-9731ed249f08c6bc74551c749733fe5d5146645e.zip
sys-apps/pkgcore: Restore last good infra version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.11.2-r2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 1377a234f2f5..011191b71894 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1,3 +1,4 @@
+DIST pkgcore-0.11.2.tar.gz 641792 BLAKE2B 295cc8302badcae333939d69329331be5f76d965549c75140ce809d693cf688fe3d3152c44a9d738aa2d90ed1c9f4aad2cf3c9a9a3a52a067e69cf7dd6c87b96 SHA512 602e7ad03699b3b3f302d6d414a9587f1c7829be83898e055e8e1a46e2a805b535cb715bbbb4d43100f77b8b119e13e8b1e374f45be879b4c9dfe02340f225d6
DIST pkgcore-0.11.5.tar.gz 637303 BLAKE2B bd7e609039253864bf02c9a6cb084b54971a37b7d18d8c8234dcea3a7f25f25ec6652f51fc451bd991727f147d1341ee8ab7ecbcb37b727966708c1248fef428 SHA512 59a31cc9166ae2b12ec2cb349a5e29ce06999c532f7007af2392773a1e6f91ae7d6fa91c123991368dfe5ebdd7edc4ccc2a23fbf008c22b7e251562c8deb8bf8
DIST pkgcore-0.11.6.tar.gz 634191 BLAKE2B c06f24006be697771dd3d7569e3a27310dca56c05047ac991c2db359838dddd5eec78c8d424e826b39968cc496be6e7eb366668bfa45082aac438b663015cb8a SHA512 e556d20100c0234d319ed2e15686a3bb9f388f1cdefd7188958c3c0b32d741dd531cbbe8d377b0736662f66b3241e633491a72a1ce84dd86790e9f543b3d0800
DIST pkgcore-0.11.8.tar.gz 631665 BLAKE2B 1e33ce394c1df9418d22fc8653fca4da1b4e27d53325167e3b7231fb8382f3c81daa7a93587ab2226116865546d4ca1ae1dd4265ccc2adc9cb9b27106d9c352b SHA512 42ed7c54db5fa48dffa5e3927afae32d1b4db92da41eff99c8eaa10232fdeae4e0f3f4d39b1e1b4e3881304523822a9a99575648809c554e3bdcf59d9eab485b
diff --git a/sys-apps/pkgcore/pkgcore-0.11.2-r2.ebuild b/sys-apps/pkgcore/pkgcore-0.11.2-r2.ebuild
new file mode 100644
index 000000000000..0de5a597644f
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.11.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+="
+ <dev-python/snakeoil-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/snakeoil-0.9.2[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pkgcore-0.10.13-metadata-xsd-2.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}