summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-28 17:06:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-28 17:34:03 +0200
commit98d82a9a646f9dccd3321e5030b6610f384b538b (patch)
treea7a8864f7ad9c7b1b67fb938ca66268590a6d6c2 /sys-apps
parentmedia-video/pipewire: Fix build with -fno-common (diff)
downloadgentoo-98d82a9a646f9dccd3321e5030b6610f384b538b.tar.gz
gentoo-98d82a9a646f9dccd3321e5030b6610f384b538b.tar.bz2
gentoo-98d82a9a646f9dccd3321e5030b6610f384b538b.zip
sys-apps/xdg-desktop-portal: Pin to media-video/pipewire:0/0.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0-r2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..777122093897
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
+IUSE="doc geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ )
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ media-libs/fontconfig
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( media-video/pipewire:0/0.2 )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-libportal # not packaged
+ )
+ econf "${myeconfargs[@]}"
+}