summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-24 12:47:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-24 12:47:42 +0200
commit9b05fa933d2450b14af4eba993badf9142bc1a86 (patch)
treec00d60e557fd0452575fe30c08fdf15eec00af90 /sys-apps
parentsys-apps/ethtool: bump to v5.3 (diff)
downloadgentoo-9b05fa933d2450b14af4eba993badf9142bc1a86.tar.gz
gentoo-9b05fa933d2450b14af4eba993badf9142bc1a86.tar.bz2
gentoo-9b05fa933d2450b14af4eba993badf9142bc1a86.zip
sys-apps/texinfo: bump to v6.7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-6.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index ea91c7c29890..e49285051a0f 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,2 +1,3 @@
DIST texinfo-6.3.tar.xz 4468048 BLAKE2B ef255225e1f66dc5e6646761d78dcf3e7ba9c79aa2654dbb527ef10db54b8417af9e1a58a270683956624049c2fb624b29bc2f22763c79bab9858cdcf5e2edce SHA512 ef6c5878d9db497d7963bd9138418b30c39a5605c215bf2f4e8f1f083d93c3c99f8c459aa675f7da3b78da6189cb6bbf3cf19a2ee1d52e569de2f6ce82762bf4
DIST texinfo-6.6.tar.xz 4946900 BLAKE2B bd33297549d5285d7a4a65041b6025c489c6b436e9591eaf5187ef34f6e869bf7a2a82a00ebe11adc1c4b2904119e9e3f25d2496b5507f91f4b9ba548ba98604 SHA512 96e0764d0808152d3662e65c3287fb0f86ed918912cdc036380637dbadaacd6a489b516543c07b08105686575e8d495a945f73e23ff0909d5a0f12026e4131e0
+DIST texinfo-6.7.tar.gz 9027808 BLAKE2B ac9a47ae98f27ae55ea1844c74ead6fba256635a56e7a226a1bbdd9ee9ab33565ff8cc7a874410afe6463741285c8fcfd8ff835ae2802009e2d0758405559140 SHA512 a52aaa2f0113c6f14b3cb94fbf7191770017ff6ce2016292770831279cfbb898c2f7f720adee620e08d9d80a9505df89a689ba0c25e92f6579b28b075f7b8ee2
diff --git a/sys-apps/texinfo/texinfo-6.7.ebuild b/sys-apps/texinfo/texinfo-6.7.ebuild
new file mode 100644
index 000000000000..43dce37a9b0f
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ standalone? ( dev-lang/perl )
+ !standalone? (
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+ local myeconfargs
+ if use standalone ; then
+ myeconfargs=(
+ --without-external-libintl-perl
+ --without-external-Unicode-EastAsianWidth
+ --without-external-Text-Unidecode
+ $(use_enable nls)
+ --disable-perl-xs
+ )
+ else
+ myeconfargs=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ $(use_enable nls)
+ --enable-perl-xs
+ )
+ fi
+ econf "${myeconfargs[@]}"
+}