summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-20 10:41:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-20 10:42:14 +0200
commit9c104264a85709b212be0cbcda659828fe6a4bd7 (patch)
tree1bdec64f7446733526879b6e31f5da499d713428 /sys-apps
parentapp-text/kjots: Fix build with >=kde-apps/kontactinterface-20.08 (diff)
downloadgentoo-9c104264a85709b212be0cbcda659828fe6a4bd7.tar.gz
gentoo-9c104264a85709b212be0cbcda659828fe6a4bd7.tar.bz2
gentoo-9c104264a85709b212be0cbcda659828fe6a4bd7.zip
sys-apps/xdg-desktop-portal: 1.8.0 version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 7e453754e2f4..25295a54740f 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-1.6.0.tar.xz 453516 BLAKE2B 13ffcb21de6b61ddeb0782dcfc7b684287e54f94b9494b19589178594d1383a15048b8f9aeed7fb1260c3a2c967b267061d1db401085a686938c8629de8824c3 SHA512 7a0c702851762a55326142cb6b470205775284e0f749620ae6b648f216afcd684f8b20500339680b42812f628634344c9e826ab7cf13dd918fdbf733381d44ce
DIST xdg-desktop-portal-1.7.2.tar.xz 468140 BLAKE2B 6f2e92f79424f79e778db9c1bf94555332f1f88ef42f84e477c8784be74ce8e2cf924f34da5e17d78359bd493370dcee62aec77f60c9df5cf3475d745f3e4d8e SHA512 fac64281e89d8bf17c6f1b3751c159d9ca6c2896b71bb83622411bf2dc9b7813974d19902c81c3576b325c98edf4dae22ccc3fe290e32f717730b6aa3afbdc12
+DIST xdg-desktop-portal-1.8.0.tar.xz 470692 BLAKE2B f21da5ad11dc2b1611983fdac87335b3c7e9c13222bbe3b90b276d75726a6f16d950a9ba62606aa31d52f57b8d076393ec0d48014b1623ab03dee23c524ed0ef SHA512 6d9760b41447af711d5937279b0031bcc88947e11204351accfcd9e6e19e498e9021675753185f92f7bd40336decc1895968796b1b71508c7caf5f6fc32a51a4
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.0.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.0.ebuild
new file mode 100644
index 000000000000..e217ed6874fe
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ media-libs/fontconfig
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-docbook-docs # flatpak not packaged
+ --disable-libportal # not packaged
+ )
+ econf "${myeconfargs[@]}"
+}