summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2020-04-20 00:29:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-21 15:44:47 +0300
commit9da3f00d340c5b64bef015484a63c6bd1620cf12 (patch)
tree8766e1e97509916729c347aa4c982fca53a22346 /sys-apps
parentnet-mail/mu: change urls to https (diff)
downloadgentoo-9da3f00d340c5b64bef015484a63c6bd1620cf12.tar.gz
gentoo-9da3f00d340c5b64bef015484a63c6bd1620cf12.tar.bz2
gentoo-9da3f00d340c5b64bef015484a63c6bd1620cf12.zip
sys-apps/bleachbit: Bump to 4.0.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-4.0.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index f1f68a470f6e..a43824159866 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,2 +1,3 @@
DIST bleachbit-3.0.tar.bz2 562646 BLAKE2B 4acdd5469ac1b36ff149231ad0b1b2e4e85a54a81c24c7751ceeed569526b905c1cc6be5201c4fb6929eb48e0553f0b27016de2584ee2f702492cc3fe659c2f9 SHA512 0d61f0b183c0d453275913741020c54c2915be9df45be706203e2278b125f4a02c75865117a7a2d587a034caa9bf109b2f498a4d522cc103c3879cc4a5d4854d
DIST bleachbit-3.9.0.tar.bz2 578754 BLAKE2B cafce09ccc45e2a1b058730597571f4ef94672376e067b2b8f5fb6df674bac48ee7ad40cb52165b38afee0513e8b687f46d27264c562f863fe29d80d08093264 SHA512 bb93825b8dffdb62058315683fc3d3c77e0b0aa9adc2901be73abeae07667e15b91a4266c6ca7cecdfcf10cef8c179d8796b39dd76866ccddc0cd50e5e097bdc
+DIST bleachbit-4.0.0.tar.bz2 599756 BLAKE2B 05a4dbf9e0b6bbcba528875a82e36eb9f91ae84c5bdc6f8f69063a54bd192332f5dd1d22ee5a737243eb5fb74cf0362eace1b50a73f7c1d0557a8cba146dea01 SHA512 ce120239b411c6e177af0e22a16b583ac3ae8903ba13579878942492e4e221355da28f737d6c78811312bfcc888af7c8dba6c153673f4e1542cc2aceedf2d2c9
diff --git a/sys-apps/bleachbit/bleachbit-4.0.0.ebuild b/sys-apps/bleachbit/bleachbit-4.0.0.ebuild
new file mode 100644
index 000000000000..8ed560185347
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[$PYTHON_USEDEP]
+ dev-python/pygobject:3[$PYTHON_USEDEP]
+"
+BDEPEND="
+ sys-devel/gettext
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+# tests fail under FEATURES=usersandbox
+RESTRICT="test"
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # fails on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}