summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-06-23 22:49:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-26 11:17:22 +0000
commita7402a02d208c581684fc9b1a041ee4225aa921f (patch)
tree7ee0f977176613650c4fadbd83f38b7376541dc9 /sys-apps
parentnet-libs/libnftnl: Version bump to 1.0.6. (diff)
downloadgentoo-a7402a02d208c581684fc9b1a041ee4225aa921f.tar.gz
gentoo-a7402a02d208c581684fc9b1a041ee4225aa921f.tar.bz2
gentoo-a7402a02d208c581684fc9b1a041ee4225aa921f.zip
sys-apps/miller: bump to v4.2.0.
Also add manpage. Closes: https://github.com/gentoo/gentoo/pull/1733 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/miller/Manifest1
-rw-r--r--sys-apps/miller/miller-4.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/miller/Manifest b/sys-apps/miller/Manifest
index 945c2fb467f4..b6205c2fad16 100644
--- a/sys-apps/miller/Manifest
+++ b/sys-apps/miller/Manifest
@@ -1 +1,2 @@
DIST miller-4.0.0.tar.gz 3320261 SHA256 c702eb3423e96fb2f39d6339117fd7678ac1b63258d0bd9b8c76859993ec1a0c SHA512 13612c18ad1d995797a760618fe4ca44c845c03f35df79cc5e981fd9d224ba60b0f3dc57ae454d32877711d216b32de5c22520cd9906f9866a5b59a3f488edb2 WHIRLPOOL d6b7851436572ba1dfb83fac362408195d242065d5547e85363a809514bafab2d5085da1813048fa34616ecf879bf9b026630567e672b152dcfa26e427d99f1a
+DIST miller-4.2.0.tar.gz 3373505 SHA256 2758a2364daad8672c4da85698b328f20178539d5f5d5866b19518cce1c83487 SHA512 f176dc2ce4e733ac1e4e331f17554d4ed089344a5f571bcc9d4b3b227f6c950fa0355f1a5b934e4f9467d9a22448e2842c586a4e6c424a98ec89170cd70b1714 WHIRLPOOL 8514bc6bde3cd3598caeb6e123ff7cec26a464818f6be43ddb51e43c8cee25f42403b3355ad5cfd11355788b8824ee497a12fb1172620935a17b28979f62fad2
diff --git a/sys-apps/miller/miller-4.2.0.ebuild b/sys-apps/miller/miller-4.2.0.ebuild
new file mode 100644
index 000000000000..8b6e03cbfea9
--- /dev/null
+++ b/sys-apps/miller/miller-4.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A tool like sed, awk, cut, join, and sort for name-indexed data (CSV, JSON, ..)"
+HOMEPAGE="http://johnkerl.org/miller"
+LICENSE="BSD-2"
+
+SLOT="0"
+SRC_URI="https://github.com/johnkerl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+DEPEND="sys-devel/flex"
+
+my_for_each_test_dir() {
+ local test_dirs=( c/{reg,unit}_test )
+ if use test ; then
+ for d in "${test_dirs[@]}" ; do
+ pushd "${d}" >/dev/null || die
+ "${@}" || die
+ popd >/dev/null || die
+ done
+ fi
+}
+
+src_prepare() {
+ default
+
+ local sed_args=(
+ # respect FLAGS
+ -e '/.*FLAGS[^=]*=/ s:(-g|-pg|-O[0-9]) ::g'
+ )
+ find -type f -name "Makefile.am" | xargs sed -r "${sed_args[@]}" -i --
+ assert
+
+ # disable docs rebuilding as they're shipped prebuilt
+ sed -e '/SUBDIRS[^=]*=/ s:doc::g' -i -- Makefile.am || die
+
+ # disable building tests automagically
+ use test || sed -e '/SUBDIRS[^=]*=/ s:[^ ]*_test::g' -i -- c/Makefile.am || die
+
+ eautoreconf
+}
+
+src_test() {
+ my_for_each_test_dir emake check
+}
+
+src_install() {
+ local HTML_DOCS=( $(usev doc) )
+
+ default
+
+ doman 'doc/mlr.1'
+}