summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-16 12:03:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-16 12:05:23 +0200
commita8fe76da1efe36a6572e82240eacf35071c1b933 (patch)
treef1469f7b5c167c0cff9df8f41b1dbe70d0a5b5b8 /sys-apps
parentwww-client/opera: Old (diff)
downloadgentoo-a8fe76da1efe36a6572e82240eacf35071c1b933.tar.gz
gentoo-a8fe76da1efe36a6572e82240eacf35071c1b933.tar.bz2
gentoo-a8fe76da1efe36a6572e82240eacf35071c1b933.zip
sys-apps/kbd: Revbump to no longer install *.a and *.la files
with USE="test". Also disabled tests until upstream fixed their test suite. Bug: https://bugs.gentoo.org/732868 Closes: https://bugs.gentoo.org/732612 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kbd/kbd-2.3.0-r1.ebuild (renamed from sys-apps/kbd/kbd-2.3.0.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/kbd/kbd-2.3.0.ebuild b/sys-apps/kbd/kbd-2.3.0-r1.ebuild
index 32395a108a73..3cb9fb4edd0d 100644
--- a/sys-apps/kbd/kbd-2.3.0.ebuild
+++ b/sys-apps/kbd/kbd-2.3.0-r1.ebuild
@@ -26,7 +26,9 @@ HOMEPAGE="http://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
-RESTRICT="!test? ( test )"
+#RESTRICT="!test? ( test )"
+# Upstream has strange assumptions how to run tests (see bug #732868)
+RESTRICT="test"
RDEPEND="
app-arch/gzip
@@ -65,6 +67,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ # USE="test" installs .a files
+ --disable-static
$(use_enable nls)
$(use_enable pam vlock)
$(use_enable test tests)
@@ -77,4 +81,7 @@ src_install() {
docinto html
dodoc docs/doc/*.html
use pam && pamd_mimic_system vlock auth account
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
}