summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 13:53:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 14:29:11 +0200
commitaa04bada4e47d9449e38918c41bfd2eec1e076f2 (patch)
tree1f4ec54f2557a4fd40fd66b4c3c564984fe1ad34 /sys-apps
parentsys-apps/dstat: Remove old (diff)
downloadgentoo-aa04bada4e47d9449e38918c41bfd2eec1e076f2.tar.gz
gentoo-aa04bada4e47d9449e38918c41bfd2eec1e076f2.tar.bz2
gentoo-aa04bada4e47d9449e38918c41bfd2eec1e076f2.zip
sys-apps/usbutils: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/usbutils/Manifest2
-rw-r--r--sys-apps/usbutils/files/usbutils-010-fix-py3-support.patch145
-rw-r--r--sys-apps/usbutils/usbutils-009.ebuild49
-rw-r--r--sys-apps/usbutils/usbutils-010-r1.ebuild53
4 files changed, 0 insertions, 249 deletions
diff --git a/sys-apps/usbutils/Manifest b/sys-apps/usbutils/Manifest
index 9ad4839eaed9..17656c91aeb1 100644
--- a/sys-apps/usbutils/Manifest
+++ b/sys-apps/usbutils/Manifest
@@ -1,3 +1 @@
-DIST usbutils-009.tar.xz 309608 BLAKE2B bb5d7f756241377e81aa8f5b074bb0ba36bc778698afaebf7054cdb153149e4f3808a7b172019434756cae8b33410643cd6a03a36277f80ead9b0f4446385fd9 SHA512 e5936a42615690c13e618655fc5eb4f414d9a84f85b860eaeb3bcf737258e05d299b09d1c5388d50c718626036ec8cac5d670ad567ceadfaab85f401f0744a8a
-DIST usbutils-010.tar.xz 308344 BLAKE2B 5f0ba85564acaf60faad0e187e7ed5c870056cf80a1e1ae888fa498429a7a9e28eaced49047f8f793bad3c59f3b515557054860286b17d9f89f915d0db5943cc SHA512 8bc197307bc34b38c406c58c939be32f0b20ce9d3e7c977472fe4c3d47e791765432e381fd8d7393df621bbd4bf159ca24a08b22441770e7ae464e767f99a2e3
DIST usbutils-012.tar.xz 98388 BLAKE2B a19d64edeb08bafe3e6a0d6be7cb5196cebb68623cfb5cd21941f109a3f3def774382bc6fe8b68398278e530417190030c8dd39ab982c088329c7acbb36cb672 SHA512 e26a60229e6eed5de670d6511dd1fa5ee3453cc5a848820531b46a1678b69378a2a45c29e24a218a8e7065c2c345356f03a2992f8298ddae6c8026d181f8de66
diff --git a/sys-apps/usbutils/files/usbutils-010-fix-py3-support.patch b/sys-apps/usbutils/files/usbutils-010-fix-py3-support.patch
deleted file mode 100644
index c95bb7321b85..000000000000
--- a/sys-apps/usbutils/files/usbutils-010-fix-py3-support.patch
+++ /dev/null
@@ -1,145 +0,0 @@
-From a7c25eadbc998bf359e5b7dac03aaea8c30d2932 Mon Sep 17 00:00:00 2001
-From: Georg Brandl <georg@python.org>
-Date: Thu, 17 May 2018 08:51:27 +0200
-Subject: [PATCH] lsusb.py: fix up Python 3 conversion
-
-- Use open() and ignore encoding errors
-- Replace removed __cmp__ by rich comparison methods
-- Convert commented-out print statements, remove unused future import
-
-Fixes #68
----
- lsusb.py.in | 50 ++++++++++++++++++++++----------------------------
- 1 file changed, 22 insertions(+), 28 deletions(-)
-
-diff --git a/lsusb.py.in b/lsusb.py.in
-index 0f4d318..083b512 100644
---- a/lsusb.py.in
-+++ b/lsusb.py.in
-@@ -12,8 +12,6 @@
-
- import os, sys, re, getopt
-
--# from __future__ import print_function
--
- # Global options
- showint = False
- showhubint = False
-@@ -53,15 +51,12 @@ class UsbClass:
- self.desc = str
- def __repr__(self):
- return self.desc
-- def __cmp__(self, oth):
-- # Works only on 64bit systems:
-- #return self.pclass*0x10000+self.subclass*0x100+self.proto \
-- # - oth.pclass*0x10000-oth.subclass*0x100-oth.proto
-- if self.pclass != oth.pclass:
-- return self.pclass - oth.pclass
-- if self.subclass != oth.subclass:
-- return self.subclass - oth.subclass
-- return self.proto - oth.proto
-+ def __lt__(self, oth):
-+ return (self.pclass, self.subclass, self.proto) < \
-+ (oth.pclass, oth.subclass, oth.proto)
-+ def __eq__(self, oth):
-+ return (self.pclass, self.subclass, self.proto) == \
-+ (oth.pclass, oth.subclass, oth.proto)
-
- class UsbVendor:
- "Container for USB Vendors"
-@@ -70,8 +65,10 @@ class UsbVendor:
- self.vname = vname
- def __repr__(self):
- return self.vname
-- def __cmp__(self, oth):
-- return self.vid - oth.vid
-+ def __lt__(self, oth):
-+ return self.vid < oth.vid
-+ def __eq__(self, oth):
-+ return self.vid == oth.vid
-
- class UsbProduct:
- "Container for USB VID:PID devices"
-@@ -81,13 +78,10 @@ class UsbProduct:
- self.pname = pname
- def __repr__(self):
- return self.pname
-- def __cmp__(self, oth):
-- # Works only on 64bit systems:
-- # return self.vid*0x10000 + self.pid \
-- # - oth.vid*0x10000 - oth.pid
-- if self.vid != oth.vid:
-- return self.vid - oth.vid
-- return self.pid - oth.pid
-+ def __lt__(self, oth):
-+ return (self.vid, self.pid) < (oth.vid, oth.pid)
-+ def __eq__(self, oth):
-+ return (self.vid, self.pid) == (oth.vid, oth.pid)
-
- usbvendors = []
- usbproducts = []
-@@ -107,7 +101,7 @@ def parse_usb_ids():
- mode = 0
- strg = ""
- cstrg = ""
-- for ln in file(usbids, "r").readlines():
-+ for ln in open(usbids, "r", errors="ignore"):
- if ln[0] == '#':
- continue
- ln = ln.rstrip('\n')
-@@ -146,7 +140,7 @@ def parse_usb_ids():
-
- def bin_search(first, last, item, list):
- "binary search on list, returns -1 on fail, match idx otherwise, recursive"
-- #print "bin_search(%i,%i)" % (first, last)
-+ #print("bin_search(%i,%i)" % (first, last))
- if first == last:
- return -1
- if first == last-1:
-@@ -233,7 +227,7 @@ def find_dev(driver, usbname):
- for nm in devlst:
- dir = prefix + usbname
- prep = ""
-- #print nm
-+ #print(nm)
- idx = nm.find('/')
- if idx != -1:
- prep = nm[:idx+1]
-@@ -404,8 +398,8 @@ class UsbDevice:
- try:
- self.nointerfaces = int(readattr(fname, "bNumInterfaces"))
- except:
-- #print "ERROR: %s/bNumInterfaces = %s" % (fname,
-- # readattr(fname, "bNumInterfaces"))a
-+ #print("ERROR: %s/bNumInterfaces = %s" % (fname,
-+ # readattr(fname, "bNumInterfaces")))
- self.nointerfaces = 0
- try:
- self.driver = readlink(fname, "driver")
-@@ -421,7 +415,7 @@ class UsbDevice:
- for dirent in os.listdir(prefix + self.fname):
- if not dirent[0:1].isdigit():
- continue
-- #print dirent
-+ #print(dirent)
- if os.access(prefix + dirent + "/bInterfaceClass", os.R_OK):
- iface = UsbInterface(self, self.level+1)
- iface.read(dirent)
-@@ -532,7 +526,7 @@ def usage():
- def read_usb():
- "Read toplevel USB entries and print"
- for dirent in os.listdir(prefix):
-- #print dirent,
-+ #print(dirent)
- if not dirent[0:3] == "usb":
- continue
- usbdev = UsbDevice(None, 0)
-@@ -590,7 +584,7 @@ def main(argv):
- fix_usbclass()
- except:
- print(" WARNING: Failure to read usb.ids", file=sys.stderr)
-- #print >>sys.stderr, sys.exc_info()
-+ #print(sys.exc_info(), file=sys.stderr)
- read_usb()
-
- # Entry point
diff --git a/sys-apps/usbutils/usbutils-009.ebuild b/sys-apps/usbutils/usbutils-009.ebuild
deleted file mode 100644
index 9b1b0feb95f9..000000000000
--- a/sys-apps/usbutils/usbutils-009.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
- https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="virtual/libusb:1=
- virtual/libudev:="
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hwids
- python? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- use python && python_fix_shebang lsusb.py.in
-}
-
-src_configure() {
- econf \
- --datarootdir="${EPREFIX}/usr/share" \
- --datadir="${EPREFIX}/usr/share/misc"
-}
-
-src_install() {
- default
- newdoc usbhid-dump/NEWS NEWS.usbhid-dump
-
- use python || rm -f "${ED}"/usr/bin/lsusb.py
-}
diff --git a/sys-apps/usbutils/usbutils-010-r1.ebuild b/sys-apps/usbutils/usbutils-010-r1.ebuild
deleted file mode 100644
index 59ef967cc21b..000000000000
--- a/sys-apps/usbutils/usbutils-010-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit python-single-r1
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
- https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="virtual/libusb:1=
- virtual/libudev:="
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hwids
- python? ( ${PYTHON_DEPS} )"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-py3-support.patch )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- use python && python_fix_shebang lsusb.py.in
-}
-
-src_configure() {
- local myeconfargs=(
- --datarootdir="${EPREFIX}/usr/share"
- --datadir="${EPREFIX}/usr/share/misc"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- newdoc usbhid-dump/NEWS NEWS.usbhid-dump
-
- use python || rm -f "${ED%/}"/usr/bin/lsusb.py
-}