summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-11-15 12:26:13 -0500
committerMike Gilbert <floppym@gentoo.org>2019-11-15 13:37:29 -0500
commitab4d42b4c700cfb08d601c7741959e6f0483705a (patch)
tree0f5916de6cea6d46f018be55f5a760c0f39c3479 /sys-apps
parentdev-python/pyparted: Add live ebuild (diff)
downloadgentoo-ab4d42b4c700cfb08d601c7741959e6f0483705a.tar.gz
gentoo-ab4d42b4c700cfb08d601c7741959e6f0483705a.tar.bz2
gentoo-ab4d42b4c700cfb08d601c7741959e6f0483705a.zip
sys-apps/kmod: rename 'ssl' USE flag to 'pkcs7'
This better expresses the effect of the --with-openssl configure option. See NEWS for more details. This also has the nice side-effect of disabling the dependency on opensssl by default, which makes kmod work without /usr mounted in early boot. Closes: https://bugs.gentoo.org/700128 Package-Manager: Portage-2.3.79_p3, Repoman-2.3.18_p2 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/kmod-26-r2.ebuild6
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild6
-rw-r--r--sys-apps/kmod/metadata.xml1
3 files changed, 7 insertions, 6 deletions
diff --git a/sys-apps/kmod/kmod-26-r2.ebuild b/sys-apps/kmod/kmod-26-r2.ebuild
index 08754b1f8b1e..4c0380e44bde 100644
--- a/sys-apps/kmod/kmod-26-r2.ebuild
+++ b/sys-apps/kmod/kmod-26-r2.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug doc libressl lzma python ssl static-libs +tools zlib"
+IUSE="debug doc libressl lzma pkcs7 python static-libs +tools zlib"
# Upstream does not support running the test suite with custom configure flags.
# I was also told that the test suite is intended for kmod developers.
@@ -36,7 +36,7 @@ RDEPEND="!sys-apps/module-init-tools
!<sys-apps/systemd-216-r3
lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
python? ( ${PYTHON_DEPS} )
- ssl? (
+ pkcs7? (
!libressl? ( >=dev-libs/openssl-1.1.0:0= )
libressl? ( dev-libs/libressl:0= )
)
@@ -93,7 +93,7 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable tools)
$(use_with lzma xz)
- $(use_with ssl openssl)
+ $(use_with pkcs7 openssl)
$(use_with zlib)
)
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 40622a08336b..8e2f199af674 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug doc lzma python ssl static-libs +tools zlib"
+IUSE="debug doc lzma pkcs7 python static-libs +tools zlib"
# Upstream does not support running the test suite with custom configure flags.
# I was also told that the test suite is intended for kmod developers.
@@ -36,7 +36,7 @@ RDEPEND="!sys-apps/module-init-tools
!<sys-apps/systemd-216-r3
lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
python? ( ${PYTHON_DEPS} )
- ssl? ( >=dev-libs/openssl-1.1.0:0= )
+ pkcs7? ( >=dev-libs/openssl-1.1.0:0= )
zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )
@@ -86,7 +86,7 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable tools)
$(use_with lzma xz)
- $(use_with ssl openssl)
+ $(use_with pkcs7 openssl)
$(use_with zlib)
)
diff --git a/sys-apps/kmod/metadata.xml b/sys-apps/kmod/metadata.xml
index 188bf47702ef..be2aa7701742 100644
--- a/sys-apps/kmod/metadata.xml
+++ b/sys-apps/kmod/metadata.xml
@@ -10,6 +10,7 @@
</maintainer>
<use>
<flag name="lzma">Enable support for XZ compressed modules</flag>
+ <flag name="pkcs7">Enable PKCS#7 signature parsing for modinfo.</flag>
<flag name="tools">Install module loading/unloading tools.</flag>
<flag name="zlib">Enable support for gzipped modules</flag>
</use>