summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-29 21:07:22 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-29 21:12:08 -0500
commitb32b4a57937ab2539b761226ff67dece6e7f5558 (patch)
tree8a91e0f060f3758bb81a84bbe8363e7ca362662f /sys-apps
parentsys-devel/gcc: revbump 13.0.1_pre20230129 to add hardening changes (diff)
downloadgentoo-b32b4a57937ab2539b761226ff67dece6e7f5558.tar.gz
gentoo-b32b4a57937ab2539b761226ff67dece6e7f5558.tar.bz2
gentoo-b32b4a57937ab2539b761226ff67dece6e7f5558.zip
sys-apps/systemd: update journald-audit patch
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/files/gentoo-journald-audit-r1.patch51
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild2
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/systemd/files/gentoo-journald-audit-r1.patch b/sys-apps/systemd/files/gentoo-journald-audit-r1.patch
new file mode 100644
index 000000000000..b5c32df788e9
--- /dev/null
+++ b/sys-apps/systemd/files/gentoo-journald-audit-r1.patch
@@ -0,0 +1,51 @@
+From 2de502ccff1cc780d9d29c4ff7e6c1e0f2d7a082 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 21 Aug 2020 13:16:17 -0400
+Subject: [PATCH] journald: do not change the kernel audit setting by default
+
+Bug: https://bugs.gentoo.org/736910
+---
+ man/journald.conf.xml | 2 +-
+ src/journal/journald-server.c | 2 +-
+ src/journal/journald.conf | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/man/journald.conf.xml b/man/journald.conf.xml
+index 50c33e4792..2e14674f42 100644
+--- a/man/journald.conf.xml
++++ b/man/journald.conf.xml
+@@ -427,7 +427,7 @@
+ kernel auditing on start-up. If disabled it will turn it off. If unset it will neither enable nor
+ disable it, leaving the previous state unchanged. This means if another tool turns on auditing even
+ if <command>systemd-journald</command> left it off, it will still collect the generated
+- messages. Defaults to on.</para>
++ messages.</para>
+
+ <para>Note that this option does not control whether <command>systemd-journald</command> collects
+ generated audit records, it just controls whether it tells the kernel to generate them. If you need
+diff --git a/src/journal/journald-server.c b/src/journal/journald-server.c
+index 022e12d83d..6b3d261af6 100644
+--- a/src/journal/journald-server.c
++++ b/src/journal/journald-server.c
+@@ -2367,7 +2367,7 @@ int server_init(Server *s, const char *namespace) {
+ .compress.threshold_bytes = UINT64_MAX,
+ .seal = true,
+
+- .set_audit = true,
++ .set_audit = -1,
+
+ .watchdog_usec = USEC_INFINITY,
+
+diff --git a/src/journal/journald.conf b/src/journal/journald.conf
+index 5a60a9d39c..64156d5463 100644
+--- a/src/journal/journald.conf
++++ b/src/journal/journald.conf
+@@ -44,4 +44,4 @@
+ #MaxLevelWall=emerg
+ #LineMax=48K
+ #ReadKMsg=yes
+-#Audit=yes
++#Audit=
+--
+2.39.1
+
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 39a2452355b2..ea3aabd5a42f 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -237,7 +237,7 @@ src_prepare() {
PATCHES+=(
"${FILESDIR}/gentoo-generator-path-r2.patch"
"${FILESDIR}/gentoo-systemctl-disable-sysv-sync-r1.patch"
- "${FILESDIR}/gentoo-journald-audit.patch"
+ "${FILESDIR}/gentoo-journald-audit-r1.patch"
)
fi