summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-01-23 13:49:06 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:11 +0000
commitb4ac1776a976b0f36795368dc982654b772edc29 (patch)
treecaa2a15d4943c1d5a180d23dfb235c00de6d31fa /sys-apps
parentsys-apps/s6-linux-utils: drop 2.4.0.2, 2.5.0.0, 2.5.0.1, 2.5.1.1 (diff)
downloadgentoo-b4ac1776a976b0f36795368dc982654b772edc29.tar.gz
gentoo-b4ac1776a976b0f36795368dc982654b772edc29.tar.bz2
gentoo-b4ac1776a976b0f36795368dc982654b772edc29.zip
sys-apps/s6-linux-utils: respect AR, CC and RANLIB
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-linux-utils/s6-linux-utils-2.5.1.3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/s6-linux-utils/s6-linux-utils-2.5.1.3.ebuild b/sys-apps/s6-linux-utils/s6-linux-utils-2.5.1.3.ebuild
index 21a3aee0c4af..a80db33ac386 100644
--- a/sys-apps/s6-linux-utils/s6-linux-utils-2.5.1.3.ebuild
+++ b/sys-apps/s6-linux-utils/s6-linux-utils-2.5.1.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Set of tiny linux utilities"
HOMEPAGE="https://www.skarnet.org/software/s6-linux-utils/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
@@ -25,9 +27,13 @@ src_prepare() {
# Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
+ tc-export AR CC RANLIB
+
econf \
--bindir=/bin \
--dynlibdir=/usr/$(get_libdir) \