summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-08-19 11:33:11 -0500
committerBen Kohler <bkohler@gentoo.org>2022-08-19 11:36:19 -0500
commitc041c2713a0901a701e844f2dd26785bcb9f13f6 (patch)
tree1ea366d44109e8208e034bba7934b72ae2ca98f8 /sys-apps
parentsys-devel/gcc: add 12.2.0 (diff)
downloadgentoo-c041c2713a0901a701e844f2dd26785bcb9f13f6.tar.gz
gentoo-c041c2713a0901a701e844f2dd26785bcb9f13f6.tar.bz2
gentoo-c041c2713a0901a701e844f2dd26785bcb9f13f6.zip
sys-apps/cpu-x: clean up USE flags a bit
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpu-x/cpu-x-4.3.1.ebuild10
-rw-r--r--sys-apps/cpu-x/metadata.xml14
2 files changed, 11 insertions, 13 deletions
diff --git a/sys-apps/cpu-x/cpu-x-4.3.1.ebuild b/sys-apps/cpu-x/cpu-x-4.3.1.ebuild
index 8f7959b187aa..61d96cc1ce04 100644
--- a/sys-apps/cpu-x/cpu-x-4.3.1.ebuild
+++ b/sys-apps/cpu-x/cpu-x-4.3.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/X0rg/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="-* ~amd64"
-IUSE="+bandwidth +dmidecode force-libstatgrab +gtk +libcpuid +libglfw +libpci +ncurses +nls opencl test"
+IUSE="+cpu force-libstatgrab +gpu +gui +ncurses +nls opencl +pci test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -23,11 +23,11 @@ COMMON_DEPEND="
x11-libs/pango
force-libstatgrab? ( sys-libs/libstatgrab )
!force-libstatgrab? ( sys-process/procps:= )
- gtk? ( >=x11-libs/gtk+-3.12:3 )
- libcpuid? ( >=dev-libs/libcpuid-0.3.0:= )
- libglfw? ( >=media-libs/glfw-3.3
+ gui? ( >=x11-libs/gtk+-3.12:3 )
+ cpu? ( >=dev-libs/libcpuid-0.3.0:= )
+ gpu? ( >=media-libs/glfw-3.3
media-libs/libglvnd )
- libpci? ( sys-apps/pciutils )
+ pci? ( sys-apps/pciutils )
ncurses? ( sys-libs/ncurses:=[tinfo] )
opencl? ( virtual/opencl )
"
diff --git a/sys-apps/cpu-x/metadata.xml b/sys-apps/cpu-x/metadata.xml
index 475445e45d94..52d661f4aca7 100644
--- a/sys-apps/cpu-x/metadata.xml
+++ b/sys-apps/cpu-x/metadata.xml
@@ -6,33 +6,31 @@
<name>Ben Kohler</name>
</maintainer>
<longdescription>
- <pkg>sys-process/cpu-x</pkg> is similar to CPU-Z (Windows), but, unlike
+ <pkg>sys-apps/cpu-x</pkg> is similar to CPU-Z (Windows), but, unlike
the latter, it is a Free and Open Source software, written in C and
designed for GNU/Linux. It can also be used in graphical mode by using
<pkg>x11-libs/gtk+</pkg>, than in text-based mode with the use of
<pkg>sys-libs/ncurses</pkg>.
</longdescription>
<longdescription lang="fr">
- <pkg>sys-process/cpu-x</pkg> est similaire à CPU-Z (Windows), mais,
+ <pkg>sys-apps/cpu-x</pkg> est similaire à CPU-Z (Windows), mais,
contrairement à ce dernier, c'est un logiciel Libre et Open Source,
écrit en C et concu pour GNU/Linux. Il peut être aussi bien utilisé en
mode graphique en utlisant <pkg>x11-libs/gtk+</pkg>, qu'en mode textuel
avec l'utilisation de <pkg>sys-libs/ncurses</pkg>.
</longdescription>
<use>
- <flag name="bandwidth">Integrate bandwidth</flag>
- <flag name="dmidecode">Integrate dmidecode</flag>
<flag name="force-libstatgrab">Use <pkg>sys-libs/libstatgrab</pkg> to instead of <pkg>sys-process/procps</pkg></flag>
- <flag name="libcpuid">Use the <pkg>sys-libs/libcpuid</pkg> library</flag>
- <flag name="libglfw">Use the <pkg>media-libs/glfw</pkg> library</flag>
- <flag name="libpci">Use the <pkg>sys-apps/pciutils</pkg> library</flag>
+ <flag name="cpu">Use the <pkg>dev-libs/libcpuid</pkg> library for CPU info</flag>
+ <flag name="gpu">Use the <pkg>media-libs/glfw</pkg> library for GPU info</flag>
+ <flag name="pci">Use the <pkg>sys-apps/pciutils</pkg> library for PCI info</flag>
<flag name="opencl">Use the <pkg>virtual/opencl</pkg> library</flag>
</use>
<use lang="fr">
<flag name="bandwidth">Intégrer bandwidth</flag>
<flag name="dmidecode">Intégrer dmidecode</flag>
<flag name="force-libstatgrab">Utiliser <pkg>sys-libs/libstatgrab</pkg> à la place de <pkg>sys-process/procps</pkg></flag>
- <flag name="libcpuid">Utiliser la bibliothèque <pkg>sys-libs/libcpuid</pkg></flag>
+ <flag name="libcpuid">Utiliser la bibliothèque <pkg>dev-libs/libcpuid</pkg></flag>
<flag name="libglfw">Utiliser la bibliothèque <pkg>media-libs/glfw</pkg></flag>
<flag name="libpci">Utiliser la bibliothèque <pkg>sys-apps/pciutils</pkg></flag>
<flag name="opencl">Utiliser la bibliothèque <pkg>virtual/opencl</pkg></flag>