summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-20 01:45:49 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-20 01:45:49 +0200
commitc4679a6e7fd46857ed1941b611ce9327c3eaf1c3 (patch)
tree1b68bf62b3b2b4f3041c7afc90d45b383bd9995c /sys-apps
parentsys-apps/ucspi-tcp: Port to EAPI 7 (diff)
downloadgentoo-c4679a6e7fd46857ed1941b611ce9327c3eaf1c3.tar.gz
gentoo-c4679a6e7fd46857ed1941b611ce9327c3eaf1c3.tar.bz2
gentoo-c4679a6e7fd46857ed1941b611ce9327c3eaf1c3.zip
sys-apps/iotools: Port to EAPI 7
Closes: https://bugs.gentoo.org/742104 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iotools/files/iotools-1.5-makefile.patch11
-rw-r--r--sys-apps/iotools/iotools-1.5.ebuild12
2 files changed, 16 insertions, 7 deletions
diff --git a/sys-apps/iotools/files/iotools-1.5-makefile.patch b/sys-apps/iotools/files/iotools-1.5-makefile.patch
new file mode 100644
index 000000000000..79d89f6f6d06
--- /dev/null
+++ b/sys-apps/iotools/files/iotools-1.5-makefile.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -33,7 +33,7 @@
+ IOTOOLS_DEBUG = -O2 -DNDEBUG
+ endif
+
+-CFLAGS = -Wall -Werror $(DEFS) $(ARCHFLAGS) $(EXTRA_CFLAGS) \
++CFLAGS = -Wall $(DEFS) $(ARCHFLAGS) $(EXTRA_CFLAGS) \
+ $(IOTOOLS_STATIC) $(IOTOOLS_DEBUG)
+ DEFS = -D_GNU_SOURCE -DVER_MAJOR=$(VER_MAJOR) -DVER_MINOR=$(VER_MINOR)
+ SBINDIR ?= /usr/local/sbin
diff --git a/sys-apps/iotools/iotools-1.5.ebuild b/sys-apps/iotools/iotools-1.5.ebuild
index d508f1263e1a..01ade1d402f3 100644
--- a/sys-apps/iotools/iotools-1.5.ebuild
+++ b/sys-apps/iotools/iotools-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Simple commands to access hardware device registers"
HOMEPAGE="https://code.google.com/p/iotools/"
@@ -14,9 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc x86"
IUSE="static make-symlinks"
-src_prepare() {
- sed -i 's:-Werror::' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_compile() {
emake \
@@ -32,7 +30,7 @@ src_install() {
# when cross-compiling will likely fail.
local known_cmds="and btr bts busy_loop cmos_read cmos_write cpu_list mem_dump mem_read16 mem_read32 mem_read64 mem_read8 mem_write16 mem_write32 mem_write64 mem_write8 mmio_dump mmio_read16 mmio_read32 mmio_read64 mmio_read8 mmio_write16 mmio_write32 mmio_write64 mmio_write8 not or pci_list pci_read16 pci_read32 pci_read8 pci_write16 pci_write32 pci_write8 runon shl shr smbus_quick smbus_read16 smbus_read8 smbus_readblock smbus_receive_byte smbus_send_byte smbus_write16 smbus_write8 smbus_writeblock xor"
case ${ARCH} in
- amd64|x86) known_cmds+=" cpuid io_read16 io_read32 io_read8 io_write16 io_write32 io_write8 rdmsr rdtsc wrmsr";;
+ amd64|x86) known_cmds+=" cpuid io_read16 io_read32 io_read8 io_write16 io_write32 io_write8 rdmsr rdtsc wrmsr";;
esac
if ! tc-is-cross-compiler ; then
local sorted_cmds=$(echo $(printf '%s\n' ${known_cmds} | LC_ALL=C sort))