summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2018-11-20 14:28:21 +0800
committerYixun Lan <dlan@gentoo.org>2018-11-20 14:30:02 +0800
commitced5658b20ceb2b385067f4dc3c5546eb50929c3 (patch)
treef902e14a201eae2ba367c8eb29c347e950358668 /sys-apps
parentdev-ruby/tins: add 1.20.2 (diff)
downloadgentoo-ced5658b20ceb2b385067f4dc3c5546eb50929c3.tar.gz
gentoo-ced5658b20ceb2b385067f4dc3c5546eb50929c3.tar.bz2
gentoo-ced5658b20ceb2b385067f4dc3c5546eb50929c3.zip
sys-apps/tuned: bump to version 2.10.0
1) only force to make it work with python2, fail to find 'procfs' in python3 2) drop x86 keyword due to dev-python/python-linux-procfs Closes: https://bugs.gentoo.org/671052 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/tuned/Manifest1
-rw-r--r--sys-apps/tuned/tuned-2.10.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index 38b23aafddbc..1b78512c74ad 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1,2 +1,3 @@
+DIST tuned-2.10.0.tar.gz 160254 BLAKE2B 0a09b4b870ec153adc62de7811af561ddb3967d459b1d5e8b6f02c5ac036ed170ad3368d18fc1b3fd40649335035cce971a54e1eda8745c77e836a3b2d892a83 SHA512 e0674533f17ac27cd3647808cda1f51d9905f563521af8cb3ffd1854098d6e2ca1adac82e542e6bdf86cce7e659303464eac50b8823167360783a75843d02a60
DIST tuned-2.7.0.tar.bz2 107541 BLAKE2B b26924a091fd78bbc7e61c8a45b49808d132eb5ebd3fdc00f96be7eaddcffd88183fa59595a29e2c402b2c434bfdb706601d397c2ebca9a5822c6a3416373465 SHA512 ce09dd854e89762fa376f7f63a59feb384940b5dbc5ad74370b33bbda3f060f09e79d2988de3535b072ad749ab7be43ccaaa46a343a9df50eec6c40d7ab85d55
DIST tuned-2.7.1.tar.bz2 107471 BLAKE2B c9259ee5ce502100edc7c537f6857de3a6af4af0be1773e0c9422c10de16b4a513d514532da26764b0a743f943577d527919f329ff48a012e269fd2a0ac59f10 SHA512 4a4785e3d20ed7f1c2969066676f5fa3d8286b500de1c63169d745e701e1410092d29429d25c13c3515d37ef73dd297945d69db176d693d4152bfbe9ba626833
diff --git a/sys-apps/tuned/tuned-2.10.0.ebuild b/sys-apps/tuned/tuned-2.10.0.ebuild
new file mode 100644
index 000000000000..133b2755a18e
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://fedorahosted.org/tuned/"
+SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-linux-procfs[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${CDEPEND}"
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/dbus
+ sys-apps/ethtool
+ sys-power/powertop
+ sys-process/procps
+ dev-util/systemtap"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^PYTHON/s/= python3/= python2/g" \
+ -e "/^DOCDIR/s/$/&\-\$(VERSION)/g" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
+ Makefile || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ python_fix_shebang "${ED}"
+}