summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-03 21:44:31 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-03 21:48:30 -0400
commitd7224d230bb9df71e463e4384103e9b1bf99127e (patch)
treeefe03858b5d5908395cbceb58c6ecb75b52662ff /sys-apps
parentsys-block/targetcli-fb: update EAPI 7 -> 8, enable Python 3.10 (diff)
downloadgentoo-d7224d230bb9df71e463e4384103e9b1bf99127e.tar.gz
gentoo-d7224d230bb9df71e463e4384103e9b1bf99127e.tar.bz2
gentoo-d7224d230bb9df71e463e4384103e9b1bf99127e.zip
sys-apps/xdg-desktop-portal-gnome: Version bump to 42.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index a8084aba273f..0ab8800747ad 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-gnome-42.1.tar.xz 117932 BLAKE2B c0c6dc7e4efbfda8996d63c191228ebf867e3fe11a0ae031b5bfd4298a33ab3b9cb9d9cecc36c1b41eeb33c54bd3bca17149e641c1131f0be7dcb2dbdf42eda8 SHA512 6843fd10e7e70f3d09c2a9b1397288f553fb44bcae30e7992790fddbc92d6c5cc966c27b7f294e2de1a139d3893c009f1480855d66c873a13861f3fe4abecee7
+DIST xdg-desktop-portal-gnome-42.3.tar.xz 119228 BLAKE2B 1cafeda9e9ad5431eb52520db19350e9ee4c9f65e0923f6f320561893a29e32fc5033f3da540dd492c3341a8cb6bf29687cbf04b027e68ee388d102ac7023cac SHA512 0704eb29af5464fa0598cb4a05451866c8bacc20ad0638f7e799e7abdb4bbd86c41efbad963c493767190ae55f9d9c5d28360ee5fbbe1c42881969d03c7e84f5
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.3.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.3.ebuild
new file mode 100644
index 000000000000..13493ee5f082
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.7
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}